No Support for iOS 9.#?

Discussions around the iPhone/iPad/iPod Touch versions of the LDS Tools Application.
timothyjhill
New Member
Posts: 2
Joined: Sat Aug 11, 2018 10:37 pm

No Support for iOS 9.#?

Postby timothyjhill » Sat Aug 11, 2018 11:01 pm

Why do I need iOS 10+ to run the latest LDS Tools update and why will my old version of LDS Tools (3.3.1 on iOS 9.3.5) no longer sync since the 3.5 version has been released?

russellhltn
Community Administrator
Posts: 24410
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: No Support for iOS 9.#?

Postby russellhltn » Sun Aug 12, 2018 1:39 am

timothyjhill wrote:Why do I need iOS 10+ to run the latest LDS Tools update

At some point, Apple doesn't let you update apps for older versions. I'm not sure if that's the case here or not.

timothyjhill wrote:why will my old version of LDS Tools (3.3.1 on iOS 9.3.5) no longer sync since the 3.5 version has been released?

The servers that ran HT/VT where shutdown. New services were created to support Ministering using a higher level of security for communication.

The shutdown of HT/VT is likely what's causing the older versions of LDS Tools on iOS to fail.
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

timothyjhill
New Member
Posts: 2
Joined: Sat Aug 11, 2018 10:37 pm

Re: No Support for iOS 9.#?

Postby timothyjhill » Fri Aug 17, 2018 4:08 pm

Thanks Russell...is there any plan to support LDS Tools on iOS 9.3.5 or is the LDS Tools app simply caught in Apple's planned obsolescence and I have no other choice than to purchase a new device?

russellhltn
Community Administrator
Posts: 24410
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: No Support for iOS 9.#?

Postby russellhltn » Fri Aug 17, 2018 5:03 pm

I haven't heard what the issue is, so I can't give a solid answer. But since it doesn't seem to be fixed by now, I wouldn't have a lot of hope.

It looks like by market share, iOS9 is only about 4.5% of iOS. The decision makers would have access to more detailed usage by members.

At minimum, I'd start watching the deals. I'm not much of a Apple watcher, but iOS9 looks to be getting long in the tooth. With the introduction of iOS12, I think "the end" will come sooner then later.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

dpgriffi
New Member
Posts: 5
Joined: Wed Feb 05, 2014 9:17 pm

Re: No Support for iOS 9.#?

Postby dpgriffi » Sun Aug 26, 2018 9:00 pm

I just tried to download LDS Tools on 9.3.5, it indicated it couldn't download the current version and asked to continue loading an older version. Installation appeared successful, however when we tried to download the database we get the message: Downloading This may take a couple of minutes depending on your connection. The progress loop goes to around 98% complete and then just hangs there. I suspect the new downloads are not compatible with the older version of LDS Tools (Version 3.3.1 (6087).

Any hope for assistance?

mschmauch
New Member
Posts: 14
Joined: Mon Jul 23, 2012 7:30 pm

Re: No Support for iOS 9.#?

Postby mschmauch » Mon Aug 27, 2018 8:59 am

Facing this exact problem. I would be good for the Church to clearly state in the release notes at least that 9.3.5 support for LDS Tools will no longer be available so people are not left spinning their wheels thinking, "If I do this one more time, it'll probably work". As you download LDS Tools from Apple Play, you do get a hint that it requires ver 10 or higher, but also implies that perhaps a previous version would be installed that would work on 9.3.5, but there is no way to verify such a plan is really available or ever will be. Church clarification is needed badly.

russellhltn
Community Administrator
Posts: 24410
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: No Support for iOS 9.#?

Postby russellhltn » Mon Aug 27, 2018 10:49 am

From what I've heard back, the church's commitment is to the current and prior version of iOS. At this point, that's iOS 10 and 11. If it works on 9, great, but no effort will be put into making it work.

Apparently, 9 doesn't support the newer APIs on security, so it's broken.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

mschmauch
New Member
Posts: 14
Joined: Mon Jul 23, 2012 7:30 pm

Re: No Support for iOS 9.#?

Postby mschmauch » Mon Aug 27, 2018 11:34 am

It would have been considerate if the Church would have warned 9.3.5 users that the latest release is not likely to work on their devices and made a way to still update the database even with missing features rather than ignore the situation and let users stumble into a dead device relative to LDS Tools. For sure, many LDS Tools developers knew in advance that most (if not all) 9.3.5 users would die with the latest update. As sad as that would be to such users, it's still better than allowing them to waste their time trying to make their device work.

russellhltn
Community Administrator
Posts: 24410
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: No Support for iOS 9.#?

Postby russellhltn » Mon Aug 27, 2018 12:02 pm

mschmauch wrote:It would have been considerate if the Church would have warned 9.3.5 users that the latest release is not likely to work on their devices and made a way to still update the database even with missing features rather than ignore the situation and let users stumble into a dead device relative to LDS Tools.

I don't disagree, but my impression is that "the developers" is a small group of people. And in this case, they had a hard deadline to roll out the new version.

What broke the old version was turning off the old HT/VT service. The fact it didn't cope well was unfortunate, but I don't know as they had any tools at that point to fix the old version before rolling out the new one.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

mschmauch
New Member
Posts: 14
Joined: Mon Jul 23, 2012 7:30 pm

Re: No Support for iOS 9.#?

Postby mschmauch » Mon Aug 27, 2018 12:48 pm

It's not too late to communicate the woes of 9.3.5 devices. I can't be the only one with the problem, and there are many who will not find this thread and are still yet hopeful that if they just carefully do it right, or get on a faster internet service, or pray more, they' will still get the new release to work. How sad for them on two levels: a dying device, and wasted time.


Return to “iPhone/iPad LDS Tools”

Who is online

Users browsing this forum: No registered users and 0 guests