Page 1 of 1

Error trying to develop Directory

Posted: Sat Jul 17, 2010 8:19 am
by YoungstromMJ
This is an email I got from Walter Holladay:

I decided to go ahead and try the LDS Tech IDE method for getting setup. I followed all the directions in the "Getting Started" path, but when I got to the "Run Application" step, I got this error:
Project build error: 'dependencies.dependency.version' is missing for org.springframework:spring-beans:jar

I looked at the pom.xml in the "directory" directory, and it had this error:

Project build error: Invalid packaging for parent POM [unknown-group-id]:[unknown-artifact-id]:[unknown-version], must be "pom" but is "jar"

Any ideas?

Posted: Sat Jul 17, 2010 9:03 am
by YoungstromMJ
I attempted to checkout directory and got an error. However, I did not get the same error as you and I believe I made it further than you. Lets try to get you to where you have the same error as me and we'll go from there.

* I gathered from the message your trying to checkout directory right? When you checked out did you checkout the "trunk" folder or the root folder? You should be checking out the "trunk" folder. If you didn't then delete your projects and try checking it out again.

* What version of the JDK are you running? There are some known problems with JDK 6 update 21. Update 21 is just a week old so if you installed your jdk earlier then you're fine. Otherwise you might want to install an older jdk (update 20) or try out the next version of our IDE currently in testing. Be sure to delete your old LDSTech folder before installing a new one.

The error I got when checking out was "Unable to download jaxme" dependency. if you get to here then I'll provide you with a patch that will work around this issue until I can talk with the developers about it on Monday.


Posted: Sat Jul 17, 2010 11:34 am
by wholladay-p40
Yes, I am trying to build and run the directory project.
I checked out the "trunk" folder/branch of SVN.
I'm using JDK 1.6.0_20

Thanks for your help, but I don't know what else to do to get to the same error as you.

I am working on a Mac if that makes any difference.

It seems like I'm missing some configuration settings.

Posted: Sat Jul 17, 2010 1:05 pm
by YoungstromMJ
When you checked out the project did you uncheck "Use default Workspace location"?

Posted: Sat Jul 17, 2010 10:30 pm
by YoungstromMJ
If you have some spare time during business hours next week perhaps I can VNC into your machine and take a quick look. I'm confident it won't take long to figure out what is going on.

If you can set up a VNC server and acquire a public IP then email the info to me and we can arrange a time, I'll call you, and take a quick look. Would that work?