Can't add new MLS user

Discussions around using and interfacing with the Church MLS program.
BrownDennisRay1
New Member
Posts: 4
Joined: Sun Jun 09, 2013 5:35 pm

Re: Can't add new MLS user

Postby BrownDennisRay1 » Wed Jun 12, 2013 3:30 pm

yes, I am the administrator for the ward. I am the ward clerk. I tried changing things, adding, deleting, all resulting in the same message. I will try changing the one username to be the same as the other and see if I get anywhere with that. I must say though. This is getting frustrating.

User avatar
aebrown
Community Administrator
Posts: 15057
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Re: Can't add new MLS user

Postby aebrown » Wed Jun 12, 2013 4:00 pm

BrownDennisRay1 wrote:I will try changing the one username to be the same as the other and see if I get anywhere with that.

Changing a user name is unlikely to help.

The problem is that you have multiple user names associated with the same MRN. Therefore the only path forward is to associate one of those problematic user names with a different MRN. You may have to choose a member who is very unlikely to ever use MLS, such as an elderly sister in the ward. That's a hack, but we're dealing with inactive MLS user accounts here (except for the one good one that should be associated with the right member). The inactive account will go away in 3 years anyway.

russellhltn
Community Administrator
Posts: 23752
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Can't add new MLS user

Postby russellhltn » Wed Jun 12, 2013 4:13 pm

aebrown wrote:The problem is that you have multiple user names associated with the same MRN. Therefore the only path forward is to associate one of those problematic user names with a different MRN.


To me, the ideal method is to merge the two users. But I don't know as there's anything that can be done on the MLS end. Perhaps LUS has a trick up their sleeve.

While associating it with another user would work, that bothers me. In the event of an investigation, it records the transactions as being done by the wrong person. A small likelihood of happening, but it's not impossible.
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

User avatar
aebrown
Community Administrator
Posts: 15057
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Re: Can't add new MLS user

Postby aebrown » Wed Jun 12, 2013 6:03 pm

russellhltn wrote:To me, the ideal method is to merge the two users. But I don't know as there's anything that can be done on the MLS end. Perhaps LUS has a trick up their sleeve.

I doubt that LUS has any capabilities for this, short of capturing the database, making changes directly to the db tables, and sending it back. That's more hassle than this is worth.

russellhltn wrote:While associating it with another user would work, that bothers me. In the event of an investigation, it records the transactions as being done by the wrong person. A small likelihood of happening, but it's not impossible.

Although it's conceivable, it's extremely unlikely. Remember that MLS started checking for duplicate MRNs with MLS 3.3, which was released in December 2010. So no duplicate users have been created since then. Thus it's quite likely that any duplicate deactivated account is dealing with transactions which (at least for the US with its 3 year retention period) are in the very oldest year. Of course, it's possible that both of the duplicated accounts continued to be used after 3.3 came out, but that's even more unlikely.

Furthermore, the transactions are connected to the user, not the person (although clearly they are indirectly connected to the person through the user). I'm not proposing anything that would change that linkage.

Short of dumping the problem on LUS, my proposal seems like the only self-service option that would work.

russellhltn
Community Administrator
Posts: 23752
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Can't add new MLS user

Postby russellhltn » Wed Jun 12, 2013 6:23 pm

aebrown wrote:Short of dumping the problem on LUS, my proposal seems like the only self-service option that would work.

Agreed. But I think it would be worth checking with them to see how they want it handled.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

BrownDennisRay1
New Member
Posts: 4
Joined: Sun Jun 09, 2013 5:35 pm

Re: Can't add new MLS user

Postby BrownDennisRay1 » Sun Jun 16, 2013 7:42 pm

I do have administrative rights. in fact, that is how the double entries occurred in the first place. I reactivated the one user and invited the person to fill in his password. He also changed the user name to his nickname and saved. This created the second username for the same person. Later he was released from the bishopric. Now when we try to activate any of the old user names we get an error. I confirmed today that I cannot create a new user name, delete old user names, change the user name even with administrative rights. This problem has to be solved by Salt Lake.

russellhltn
Community Administrator
Posts: 23752
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Can't add new MLS user

Postby russellhltn » Sun Jun 16, 2013 8:38 pm

BrownDennisRay1 wrote:I reactivated the one user and invited the person to fill in his password. He also changed the user name to his nickname and saved. This created the second username for the same person.


That certainly sounds like a bug. Changing the name shouldn't create a new user.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

enomichael
New Member
Posts: 2
Joined: Fri Apr 27, 2018 7:46 am

Re: Can't add new MLS user

Postby enomichael » Sun May 13, 2018 9:14 am

how do i add users to mls

russellhltn
Community Administrator
Posts: 23752
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Can't add new MLS user

Postby russellhltn » Sun May 13, 2018 12:28 pm

enomichael wrote:how do i add users to mls

You can find that information in the Help Center under Maintain MLS User Access.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.


Return to “MLS Support, Help, and Feedback”

Who is online

Users browsing this forum: No registered users and 2 guests