Why does ministering require LDS Tools 3.5?

Any discussions around the LDS Tools App on various mobile and electronic devices
scgallafent
Church Employee
Church Employee
Posts: 1646
Joined: Mon Feb 09, 2009 4:55 pm
Location: Riverton, Utah

Why does ministering require LDS Tools 3.5?

Postby scgallafent » Fri Aug 10, 2018 10:14 pm

For a couple of days, I have been trading private messages with one of the forum moderators about some of the ministering changes and how they affect LDS Tools. During the course of our discussion, I came to realize that I wasn't clearly conveying why users who could see ministering data in LDS Tools 3.4 have to update to LDS Tools 3.5 to continue to see ministering data. Now that I realize that is a problem, I thought it would be good to post a general message with an explanation.

First, it is important to know that the old home and visiting teaching application (HT/VT) was a separate application that lived alongside Leader and Clerk Resources. Although they appeared (for the most part) to be the same application, they were separate pieces of software.

When the First Presidency's announcement regarding the ministering changes was made at General Conference, we released changes to LCR, HT/VT, and LDS Tools to begin the process of replacing home and visiting teaching with ministering. Those changes included immediately (on April 1) renaming the existing HT/VT functionality to ministering so that wards and branches could continue to use the HT/VT application to manage assignments while the new ministering software was completed.

The new ministering application was released on August 1. This is a new application -- not an upgrade of the existing application. That means there is a new database, new servers, and new internal APIs for communicating data between systems. The assignment data was migrated from the HT/VT database and the existing HT/VT system was shut down.

The "ministering" data in LDS Tools 3.4 was data coming from the old HT/VT system. LDS Tools 3.4 understood how to talk to the old HT/VT system but had no support for communicating with the new system. Now that that system has been shut down, LDS Tools 3.4 doesn't have any data to display. You must be using LDS Tools 3.5 to see data in the new ministering database.

The other question that has been coming up is why LDS Tools 3.5 is only supported on Android 5 (Lollipop) or later, which effectively means that ministering data is only available on devices with Android 5 or later.

There are technical changes between Android 4 and Android 5 related to encryption of network requests. LDS Tools 3.5 uses newer cryptographic protocols that are not fully supported in Android 4. Android 4 devices do not adequately support the current industry standards for secure communication.

For the time being, LDS Tools 3.4 will continue to work on older devices, but the new functionality in LDS Tools 3.5, which uses the newer protocols, is only available on Android 5 or later. This decision wasn't made lightly and there was discussion about the number of users affected, but those effects need to be balanced against the need to use current security standards to protect member and Church data.

Excel70
New Member
Posts: 1
Joined: Sun Aug 12, 2018 9:12 am

Re: Why does ministering require LDS Tools 3.5?

Postby Excel70 » Sun Aug 12, 2018 9:14 am

I have Android version 5.1.1 and LDS Tools version 3.5.0 and I cannot see any Ministering information. Any tips or insight?

russellhltn
Community Administrator
Posts: 24721
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Why does ministering require LDS Tools 3.5?

Postby russellhltn » Sun Aug 12, 2018 12:36 pm

Excel70 wrote:I have Android version 5.1.1 and LDS Tools version 3.5.0 and I cannot see any Ministering information. Any tips or insight?


Use the in-app feedback. It will send a resport that will help the developers figure it out.
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

Lary
New Member
Posts: 1
Joined: Sun Aug 12, 2018 3:04 pm

Re: Why does ministering require LDS Tools 3.5?

Postby Lary » Sun Aug 12, 2018 3:13 pm

I also am unable to see any Ministering information (either who ministers to me or the folks to whom I minister). Currently running Android version 8.0.0 and Samsung Experience version 9.0.


Return to “LDS Tools”

Who is online

Users browsing this forum: No registered users and 1 guest