LDSTech 1.1.2 auto escaping

Support and Announcements for the LDS Tech Java Web Application Platform (setup, configuration, bugs, feedback).
tlmaravilla
New Member
Posts: 25
Joined: Tue Feb 01, 2011 5:34 pm
Location: Riverton, UT

LDSTech 1.1.2 auto escaping

Postby tlmaravilla » Thu Feb 03, 2011 1:38 pm

Didn't have this behavior in the older LDSTech client, but now when I copy and paste in a java class, I get auto escapes and \t\n, Example:

Now if I copy "with networkId: " + networkId + ", scriptEnum: " + scriptEnum;"

and paste it, I see:
with networkId: \" + networkId + \", scriptEnum: \" + scriptEnum;



If i copy:
String msg = "with networkId: " + networkId + ", scriptEnum: " + scriptEnum
+ ", retrvdEnum: " + retrvdEnum;


paste:
with networkId: \" + networkId + \", scriptEnum: \" + scriptEnum\r\n" +
" + \", retrvdEnum: \" + retrvdEnum;

I would rather not have the escapes and \r\n added for me, I am sure this can be turned off, but now sure where in eclipse turn this off.

Thanks

tlmaravilla
New Member
Posts: 25
Joined: Tue Feb 01, 2011 5:34 pm
Location: Riverton, UT

Postby tlmaravilla » Thu Feb 03, 2011 1:41 pm

Never mind, found it:
Windows --> Preferences --> Java --> Editor --> Typing --> In string literals --> Escape text when pasting into string literals

just uncheck that and I am good to go

UreskSJ
Church Employee
Church Employee
Posts: 14
Joined: Wed Mar 11, 2009 4:32 pm
Location: Herriman, UT, US

Postby UreskSJ » Thu Feb 03, 2011 3:31 pm

I've noted your experience with this preference here:

https://tech.lds.org/jira/browse/STACK-2983

We'll probably turn this off by default in the next version of the IDE. Feel free to comment on that issue with any other preferences you wish were off or on by default.
- Spencer Uresk
Java Stack Team


Return to “Java Web Project Support (Stack)”

Who is online

Users browsing this forum: No registered users and 1 guest