Problem with Android 5 and WiFi on the 881W

Discussions about Internet service providers (ISPs), the Meetinghouse Firewall, wired and wireless networking, usage, management, and support of Meetinghouse Internet
le_jawa
New Member
Posts: 4
Joined: Sun Apr 26, 2015 9:21 am
Location: Reynoldsburg, OH, USA

Problem with Android 5 and WiFi on the 881W

Postby le_jawa » Sun Oct 18, 2015 4:29 pm

All,

We've run into a problem that I wanted to see if anyone else is experiencing. Some of our members with Android 5 devices (as well as the one person with a Chromebook :lol: ) are having trouble connecting to WiFi at our stake center. Windows, OS X, iOS (and even Linux, AFAIK) all seem to be unaffected, as well as Android 4. Some devices simply won't connect, others throw an error, then still connect anyway.

Has anyone else seen this, and is there a workaround or fix for it? I've just started my troubleshooting, so I'll post anything else I find here.

Thanks y'all!

Jason Lewis
Columbus Ohio South Stake
Jason Lewis
Stake Technology Specialist
Columbus Ohio South Stake, USA

User avatar
sbradshaw
Senior Member
Posts: 2494
Joined: Mon Sep 26, 2011 8:42 pm
Location: Provo, UT
Contact:

Re: Problem with Android 5 and WiFi on the 881W

Postby sbradshaw » Sun Oct 18, 2015 5:53 pm

I wonder if it is related to the DNS problem that Chomecasts run into?
Samuel Bradshaw • Interested in church apps and sites, creative recordkeeping, clerk support, YSA wards and stakes, LDS music, Vineyard at BYU, and online service.

russellhltn
Community Administrator
Posts: 20762
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Problem with Android 5 and WiFi on the 881W

Postby russellhltn » Sun Oct 18, 2015 9:43 pm

Googling for "Android 5 WiFi Problem" seems to turn up a number of hits. I noticed my Nexus 7 has yet another update.

Edit: My Nexus is now up to 5.1.1
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

russellhltn
Community Administrator
Posts: 20762
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Problem with Android 5 and WiFi on the 881W

Postby russellhltn » Wed Oct 21, 2015 10:12 pm

My Nexus 7 is happy to connect to the 1041 WAP. It used a remembered connection and latched on immediately.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

le_jawa
New Member
Posts: 4
Joined: Sun Apr 26, 2015 9:21 am
Location: Reynoldsburg, OH, USA

Re: Problem with Android 5 and WiFi on the 881W

Postby le_jawa » Thu Jun 23, 2016 11:01 am

Oh man, I just realized that I forgot to come back and post the resolution for this. It turned out to be a rogue access point giving out IP addresses that were completely different from those on our LAN. Something about the Android DHCP client seemed to prefer that DHCP server over the Cisco one, or perhaps the other clients just did better checking to see which DHCP server matched the addresses on the network.
Jason Lewis
Stake Technology Specialist
Columbus Ohio South Stake, USA

russellhltn
Community Administrator
Posts: 20762
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Problem with Android 5 and WiFi on the 881W

Postby russellhltn » Thu Jun 23, 2016 11:24 am

le_jawa wrote:Something about the Android DHCP client seemed to prefer that DHCP server over the Cisco one, or perhaps the other clients just did better checking to see which DHCP server matched the addresses on the network.

As far as I know, it's a "race" condition - the unit picks up the first response. So if the Cisco was a bit slow or otherwise occupied.... Perhaps some clients have figured out a way to deal with it.

How did you find and disable the rogue DHCP?
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.


Return to “Meetinghouse Internet”

Who is online

Users browsing this forum: No registered users and 1 guest