What version of Internet Explorer is required for online audits?

Use this forum to discuss issues that are not found in any of the other clerk and stake technology specialist forums.
ron09
New Member
Posts: 5
Joined: Sun Feb 05, 2012 9:02 am

What version of Internet Explorer is required for online audits?

Postby ron09 » Sat Aug 18, 2012 10:02 am

[INDENT]I'm a stake auditor. I was doing an online audit using LUFAS and got to the point where I had entered all the figures for donations and deposits but Lufas wouldn't let me go any farther because IE was an older version. A problem with the computer wouldn't let me update it so I had to start over and do the audit all on paper.

Does anyone know then minimum version of IE that is required for online audits?

Ron [/INDENT]

Return to “General Clerk Discussions”

Who is online

Users browsing this forum: No registered users and 2 guests