Windows Installer popping up every few minutes, related to Sophos

Discussions around the setup, operation, replacement, and disposal of clerk computers, not to include using MLS
New Member
Posts: 49
Joined: Mon May 18, 2009 6:44 pm
Location: Alexandria, VA

Windows Installer popping up every few minutes, related to Sophos

Postby kylehart » Mon Nov 05, 2012 1:22 pm

Title pretty much says it all.

Event logs say this:

[size=75]Product: Sophos AutoUpdate -- Internal Error 2324. 6, C:\Program Files\Sophos\AutoUpdate\ps.crl
For more information, see Help and Support Center at


[size=75]Detection of product '{15C418EB-7675-42BE-B2B3-281952DA014D}', feature 'Main', component '{C5B6DBD3-385B-435D-821A-D60C0C07DB42}' failed. The resource 'C:\Program Files\Sophos\AutoUpdate\swlocale.dll' does not exist.
For more information, see Help and Support Center at


Detection of product '{15C418EB-7675-42BE-B2B3-281952DA014D}', feature 'Main' failed during request for component '{ADECE077-A75A-4666-819F-AEBB42F82CDC}'

These popups occur all the time, and are particulalry annoying when in MLS. Any ideas how to make them stop? Looks like an update of Sophos failed at some point. Thanks

Community Moderators
Posts: 3173
Joined: Sun Jan 13, 2008 6:48 pm
Location: California

Postby techgy » Mon Nov 05, 2012 3:03 pm

I suggest that you contact the Stake Technology Specialist and have him do a re-install of Sophos.
Have you read the Code of Conduct?

User avatar
Posts: 77
Joined: Wed Aug 25, 2010 4:03 pm
Location: Corvallis, OR, USA

Postby benjamincarleski » Mon Nov 05, 2012 9:33 pm

We have had the same problem. We reported it to the Stake Technology Specialist, but he didn't have any idea. I suggested he call Salt Lake, but I don't think that has happened since the popups are still occurring. If you get it resolved, please post back what it took so that I can point him in the right direction.

Posts: 220
Joined: Tue Jan 05, 2010 2:50 pm
Location: Texas, United States

Postby sammythesm » Tue Nov 06, 2012 6:41 am

I had this issue on one of my computers. It seemed to go away after I resolved the Sophos Autoupdater problem using their FixIssues.exe script.

New Member
Posts: 49
Joined: Mon May 18, 2009 6:44 pm
Location: Alexandria, VA

Postby kylehart » Thu Nov 08, 2012 7:32 pm

Stake Tech guy fixed it via a call to SLC. But he also did a Windows System Restore (on XP) leaving us with old MLS data. I restored from backup and MLS looks good. But changes made to the MLS user login database seemed to have been "restored" to a previous point in time, losing changes. Also seems this DB is not stored with the normal backup files.

It's Sophos problem seems to be causing a lot of people a lot of time.

Posts: 90
Joined: Tue Jun 08, 2010 9:01 pm
Location: Utah County, USA

Postby KeithWilson » Sun Nov 11, 2012 5:45 pm

This is happening in one of my units. It's an XP machine, about a year old. I have run all the updates, re-installed the latest version of Sophos, ran the fixer (to which I got a dialog box that said, "Could not resolve the issue. The script encountered an error. Please contact technical support. Refer to log file.."

After restarting a couple of times, the error I get now seems that it can't find the update.
While it is running the updates, it appears the system is not getting the virus client and definitions from the right place, or the file is taking too long to download, so it generates an error. Anyone out there have any ideas from here?

New Member
Posts: 8
Joined: Sun Dec 02, 2012 5:18 pm

Postby jswalberg » Sun Dec 02, 2012 5:28 pm

I had this problem. The cause was a Sophos update that was pushed to the machine on September 19th. The installer got hung up and didn't finish installing properly.

The fix:

Right click on My Computer on the desktop or in the Start menu, and click on Manage. Expand the Services tab on the left. Scroll down in the list of services to Windows Installer. Right click on it and click Properties. Change it to Disabled.

Reboot your computer, and wait for Sophos, etc to fire up. Make sure everything has finished starting before proceeding.

Go delete this file (back it up somewhere or change the name): C:\Program Files\Sophos\AutoUpdate\ps.crl

Now go change the Windows Installer back to "Manual" (instead of Disabled). Then right click on Sophos Anti-Virus in the lower right corner (system tray) and have it try to update the latest definitions. It'll find some new software that needs to be installed. Let it install the software and download the latest virus definitions.

Return to “Clerk Computers”

Who is online

Users browsing this forum: No registered users and 1 guest