Dell Keyboard Remapping in MLS

Discussions around the setup, operation, replacement, and disposal of clerk computers, not to include using MLS
gpetersen-p40
New Member
Posts: 30
Joined: Mon Oct 22, 2007 8:47 pm
Location: Sacramento, California, USA

Dell Keyboard Remapping in MLS

Postby gpetersen-p40 » Sun May 11, 2008 10:42 pm

I have a Dell Optiplex 740 that ocasionally remaps the keyboard while in MLS. It has happened several times under MLS 2.8.0. Never under MLS 2.8.1 and once under MLS 2.8.2 (not that that necessarily means anything). Does anyone know of a particular keystroke sequence that I could accidently be "fat-fingering" that would cause this? It only appears that MLS is the only program affected. When I open up Notepad or Word, the keyboard works fine. I usually have to reboot the computer in order to restore the keyboard to work normally for MLS.

russellhltn
Community Administrator
Posts: 20735
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Sun May 11, 2008 11:06 pm

When you say "remaps" what happens?

Something I've had happen to non-MLS programs is somehow the computer looses the fact I've let go of a Alt key.* The cure is simply to press and release the Alt key. Since there's two of them, I do both (since I think each one has a unique key code.)

I've not experienced it with the ctrl or shift key(s), but it could happen.

Since MLS runs under Java, maybe it's something in Java that gets messed up. That would leave other programs unaffected.


* Just to explain, the keyboard doesn't send key combinations. It sends a keycode each and every time you press or release a key. So if I press "Alt-a" what it's really sending is something like: <LeftALT>, <a>, </a>, </LeftALT>. It's up to the computer to realize that I was pressing ALT at the time I tapped the "a" key. Of course if the computer looses that last key release, then everything is "alt". For example, if I hit "a", it behaves as if I've hit "Alt-a".

gpetersen-p40
New Member
Posts: 30
Joined: Mon Oct 22, 2007 8:47 pm
Location: Sacramento, California, USA

Postby gpetersen-p40 » Sun May 11, 2008 11:37 pm

By remapping I mean that when I hit a particular letter key, it prints a different letter. For example, if I type the letter "t" it might type the letter "p". It makes it tough when entering donor names not to mention the fact that it makes it impossible to enter the correct password when authenticating a donation batch!

The example above is not necessarily reality, but an example of the type of problem I was having. I am wondering now if somehow I am toggling a switch to change from a "qwerty" keyboard to a "dvorak" keyboard layout. Any ideas?

The_Earl
Member
Posts: 278
Joined: Wed Mar 21, 2007 8:12 am

Postby The_Earl » Mon May 12, 2008 9:00 am

If you have more than one keyboard layout installed, left-shift+alt will switch between the layouts. You probably have a little blue box in your taskbar with a code in it for your current keyboard.

You can edit your keyboard settings, including the hotkey sequences to change keyboards, and jump to a specific one from:
Control Panel -> Region and Language Settings -> Language -> Details

Let me know if that helps
The Earl

gpetersen-p40
New Member
Posts: 30
Joined: Mon Oct 22, 2007 8:47 pm
Location: Sacramento, California, USA

Postby gpetersen-p40 » Sun May 25, 2008 11:46 am

The Earl wrote:If you have more than one keyboard layout installed, left-shift+alt will switch between the layouts. You probably have a little blue box in your taskbar with a code in it for your current keyboard.

You can edit your keyboard settings, including the hotkey sequences to change keyboards, and jump to a specific one from:
Control Panel -> Region and Language Settings -> Language -> Details

Let me know if that helps
The Earl


I experienced the dvorak keyboard switch again today. Although the left-shift+alt wouldn't change it back to qwerty and I didn't see a little blue box in the taskbar, I was able to remove the dvorak keyboard option following your "Control Panel -> Region and Language Settings -> Language -> Details" instructions and all is well. Thanks for your help.

jdlessley
Community Moderators
Posts: 6522
Joined: Sun Mar 16, 2008 11:30 pm
Location: USA, TX

Postby jdlessley » Sun May 25, 2008 6:51 pm

When you used the control panel>Regional Language Options applet to reset the keyboard did you notice any other 'Installed services' (keyboard layout configurations) other than English (United States)>Keyboard>US ? You may have seen English (United States)>Keyboard>United States-Dvorak. You can safely delete the Dvorak service. In fact you should only see the English (United States)>Keyboard>US on a Church administrative computer in the United States. Any other service (keyboard layout) would have been installed by or with the knowledge of the stake technology specialist. Check with him if you do have any other service installed.

You may also have a keyboard remapping program or even a malware program installed on the computer. Check the control panel>Add or Remove Programs applet to see if there is any unrecognizable program(s) installed. This is normally something the stake technology specialist should do because he should be familiar with all authorized installs on Church administrative computers.

I would also look for any files on the computer with the .klc extension. These are files used by Windows to remap the key codes as well as install an alternate keyboard driver (other than the normal keyboard driver) on the computer. In this case you will not notice any icon in the system tray and you may not notice an alternate service (keyboard layout configuration) when you call up the keyboard settings in the Regional Language Options applet.

I am not completely familiar with the Language bar in Windows XP but it is installed by default and loaded on each boot up. If you see the Language bar icon on the right of the Task bar someone may be inadvertently 'calling' a feature of the Language bar to remap the keyboard. You can remove the Language bar by right clicking the icon and selecting to remove it. You will get a message that states you can regain the Language bar throught the Regional Language Options applet. With the Language bar removed you may prevent inadvertent keyboard remapping.

The_Earl
Member
Posts: 278
Joined: Wed Mar 21, 2007 8:12 am

Postby The_Earl » Tue May 27, 2008 12:28 pm

jdlessley wrote:... Any other service (keyboard layout) would have been installed by or with the knowledge of the stake technology specialist. Check with him if you do have any other service installed.
...


I would think that installing a Dvorak keymap would be an explicit action by an administrative user. If that is the case, your problem may reappear.

If that happens, you may want to map a hotkey sequence to the US-QWERTY mapping, so that if you ever end up with a strange key mapping, you would simply enter the hotkey sequence to get you back to qwerty. The next step would be finding out who / why the keyboard gets remapped.


Return to “Clerk Computers”

Who is online

Users browsing this forum: No registered users and 1 guest