General Conference Video not playing

Discuss ideas and suggestions around the website.
New Member
Posts: 4
Joined: Fri Feb 04, 2011 8:15 am
Location: Mendon, UT, USA

General Conference Video not playing

Postby mjkenning » Mon Apr 11, 2016 9:30 am

Been re-watching general conference and noticed a strange problem. Watched the first two talks from Saturday morning without a problem. Then on Wednesday, the third talk's video would not play. Tried on two different computers (Windows 10) with Edge, Chrome and Firefox browsers (latest version). Also tried on my iPad Air (iOS 9.3.1) in Safari and the same thing happened. Later that day, I tried again and it worked. I watched the next talk last night without a problem, but now (10:30am MT) I cannot watch Elder Duncan's talk.

Another related problem, I cannot click on any of the links on that page (Audio, download, print, share). It seems as if the page's links are blocked or broken. My ISP is Comcast, but I just tried is on my iPhone (Verizon) and it did the same thing, so I don't think it is ISP-related.

Is there something going on with the church's back-end? If so, it would be nice to get a notice instead of just nothing...

New Member
Posts: 18
Joined: Sun Jan 02, 2011 11:49 pm

Re: General Conference Video not playing

Postby paulw » Mon Apr 11, 2016 5:39 pm

At the bottom of each web page there should be a feedback link. That has worked for me every time I have questions or problems with content. If you leave contact info they'll get back to you.

User avatar
Senior Member
Posts: 2406
Joined: Mon Sep 26, 2011 8:42 pm
Location: Provo, UT

Re: General Conference Video not playing

Postby sbradshaw » Tue Apr 12, 2016 5:42 pm

Do you have JavaScript and/or Flash turned off in your browser? That could cause unexpected results in some cases.
Samuel Bradshaw • Interested in church apps and sites, creative recordkeeping, clerk support, YSA wards and stakes, LDS music, Vineyard at BYU, and online service.

Community Administrator
Posts: 20453
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: General Conference Video not playing

Postby russellhltn » Tue Apr 12, 2016 6:54 pm

There's a parallel thread here. When I asked about it, the developers were aware of it and knew how to fix it when it broke. But didn't know why it was breaking.
Have you searched the Wiki?
Try using a Google search by adding "" to the search criteria.

Return to “ Website”

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest