lds.org and IE11

Discuss ideas and suggestions around the LDS.org website.
russellhltn
Community Administrator
Posts: 20778
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

lds.org and IE11

Postby russellhltn » Sat Mar 01, 2014 12:47 pm

lds.org seems a be screwy today. Under IE11, the entire top part that contains the logo, tools, login, etc. is missing.

Looks fine in Chrome.
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

User avatar
benjamincarleski
Member
Posts: 77
Joined: Wed Aug 25, 2010 4:03 pm
Location: Corvallis, OR, USA

Re: lds.org and IE11

Postby benjamincarleski » Sat Mar 01, 2014 2:03 pm

I am able to visit the site in IE11 and the top appears the same as when I visit it in Chrome. I do notice that in IE11 it redirects to https://www.lds.org/?lang=eng while in Chrome I'm redirected to https://www.lds.org/centerpiece?lang=en ... =64165:1:0 when I simply type http://www.lds.org into the browser bar. I also notice that the Chrome page has a significantly different layout below the main image than I get in IE. Maybe they are making some changes today and trying out different layouts.

mevans
Senior Member
Posts: 1282
Joined: Tue May 22, 2012 12:52 pm
Location: California, USA

Re: lds.org and IE11

Postby mevans » Sat Mar 08, 2014 5:45 am

I don't think the problem has to do with IE11. I've seen this occur several times recently while on Safari (Mac) and possibly Chrome (Mac).

russellhltn
Community Administrator
Posts: 20778
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: lds.org and IE11

Postby russellhltn » Sat Mar 08, 2014 12:00 pm

It seems to do with the default way different browsers handle "lds.org". Chrome (on Windows) adds a "www". IE does not. That seems to be the difference. (or at least one of the differences.) When I enter "www.lds.org" into IE, it then looks normal.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

mevans
Senior Member
Posts: 1282
Joined: Tue May 22, 2012 12:52 pm
Location: California, USA

Re: lds.org and IE11

Postby mevans » Mon Mar 10, 2014 5:23 am

russellhltn wrote:It seems to do with the default way different browsers handle "lds.org". Chrome (on Windows) adds a "www". IE does not. That seems to be the difference. (or at least one of the differences.) When I enter "www.lds.org" into IE, it then looks normal.


I think you're on to something.

In Safari (Mac) I usually go to lds.org, not www.lds.org. It doesn't automatically add the "www" and then I don't get the header.

To experiment, I tried going to https://lds.org in both Chrome (Mac) and Firefox (Mac). That prevents it from adding the "www" and I get the same headerless experience. They must have changed the web site configuration recently and missed something, as I frequently don't enter the "www" and it used to work.

User avatar
aebrown
Community Administrator
Posts: 14693
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Re: lds.org and IE11

Postby aebrown » Mon Mar 10, 2014 6:18 am

mevans wrote:In Safari (Mac) I usually go to lds.org, not http://www.lds.org. It doesn't automatically add the "www" and then I don't get the header.

To experiment, I tried going to https://lds.org in both Chrome (Mac) and Firefox (Mac). That prevents it from adding the "www" and I get the same headerless experience.

Interesting. On Windows, I used Chrome, Firefox, and Safari, and in all three cases, when I entered "lds.org" I was redirected to www.lds.org and I had the header. So my experience on Windows 7 is different from your on a Mac in this regard.

mevans wrote:To experiment, I tried going to https://lds.org in both Chrome (Mac) and Firefox (Mac). That prevents it from adding the "www" and I get the same headerless experience.

When I type in https://lds.org, on all three browsers it does stick with lds.org (no www), and I also get the headerless experience, the same as you see on your Mac.

User avatar
sbradshaw
Senior Member
Posts: 2501
Joined: Mon Sep 26, 2011 8:42 pm
Location: Provo, UT
Contact:

Re: lds.org and IE11

Postby sbradshaw » Mon Mar 10, 2014 1:58 pm

benjamincarleski wrote:I do notice that in IE11 it redirects to https://www.lds.org/?lang=eng while in Chrome I'm redirected to https://www.lds.org/centerpiece?lang=en ... =64165:1:0 when I simply type http://www.lds.org into the browser bar. I also notice that the Chrome page has a significantly different layout below the main image than I get in IE. Maybe they are making some changes today and trying out different layouts.

What you are experiencing here is A/B testing of different versions of LDS.org for analytics research. According to a "Media and Technology Briefs" workforce newsletter, five percent of traffic to LDS.org is currently being directed to the "centerpiece" page with the circular images, and analytics are being used to see if "users click on more content, spend more time on the site, and visit more frequently."

mevans
Senior Member
Posts: 1282
Joined: Tue May 22, 2012 12:52 pm
Location: California, USA

Re: lds.org and IE11

Postby mevans » Wed Mar 12, 2014 12:32 pm

sbradshaw wrote:
benjamincarleski wrote:I do notice that in IE11 it redirects to https://www.lds.org/?lang=eng while in Chrome I'm redirected to https://www.lds.org/centerpiece?lang=en ... =64165:1:0 when I simply type http://www.lds.org into the browser bar. I also notice that the Chrome page has a significantly different layout below the main image than I get in IE. Maybe they are making some changes today and trying out different layouts.

What you are experiencing here is A/B testing of different versions of LDS.org for analytics research. According to a "Media and Technology Briefs" workforce newsletter, five percent of traffic to LDS.org is currently being directed to the "centerpiece" page with the circular images, and analytics are being used to see if "users click on more content, spend more time on the site, and visit more frequently."


The actual problem we're observing is that the page header (with the church logo and login info) doesn't always appear.

It's nice to know something about the "centerpiece" thing. It redirects me to that much more than 5% of the time. I really like the old design better; I find it much easier to navigate and discover things.

WardWitch
New Member
Posts: 1
Joined: Thu Jun 12, 2014 5:50 pm

Firefox https://www.lds.org/centerpiece?lang=eng&lang=eng&s_

Postby WardWitch » Thu Jun 12, 2014 6:17 pm

I've got some ward clerk computers that redirect to https://www.lds.org/centerpiece?lang=en ... =69730:1:0 when browsing to lds.org. It happens no matter what is in the address (www.lds.org or lds.org -- both http and https). On one ward computer it happens in bot IE and Firefox. On my home PC it does this in Firefox but works normally in Chrome.

The problem is when it redirects all you get is a Page Not Found error. If you change the language from English (browse to https://www.lds.org/?lang=spa) then it works fine -- if you read Spanish.

User avatar
sbradshaw
Senior Member
Posts: 2501
Joined: Mon Sep 26, 2011 8:42 pm
Location: Provo, UT
Contact:

Re: lds.org and IE11

Postby sbradshaw » Thu Jun 12, 2014 6:28 pm

Maybe they forgot to un-redirect those 5% of users after the testing was over – I'd send feedback via the LDS.org feedback page...


Return to “LDS.org Website”

Who is online

Users browsing this forum: No registered users and 1 guest