Page 1 of 4

Language problem

Posted: Fri Aug 17, 2012 12:15 pm
by gayle01
I am an administrator/builder scheduler. When I sign in, the page is listed as English, but when the tools, menu, etc. page comes up it is in Spanish. Please give instructions as to how I change & save my pages in 'English'...

Posted: Fri Aug 17, 2012 12:27 pm
by aebrown
gayle01 wrote:I am an administrator/builder scheduler. When I sign in, the page is listed as English, but when the tools, menu, etc. page comes up it is in Spanish. Please give instructions as to how I change & save my pages in 'English'...


In your browser's address bar, do you see "lang=spa" anywhere in the address (URL)? If so, that's an indication that somehow your LDS.org pages are being asked to be displayed in Spanish, so it's not surprising.

Do you see only the Calendar in Spanish, or are all the pages on LDS.org in Spanish once you sign in?

Does your header include the word "Idiomas" in the upper right corner? If so, click that, and in the dropdown that appears, choose "English."

Posted: Fri Aug 17, 2012 12:30 pm
by russellhltn
Depending on the page, you should either see a icon that looks like planet earth, or the word "languages" ("idiomas") with a drop-down list on the first first line of the webpage.

If that fails, I'd suggest clearing your browser cookies.

Posted: Fri Aug 17, 2012 4:01 pm
by Mikerowaved
I think there's a bigger underlying problem with the site. Starting earlier today, every time I go to lds.org with Firefox, it comes up in Russian. I can select English from the little "globe" icon, but the next time I visit, it goes back to Russian.

This only happens with Firefox on this particular computer. I don't experience this problem with either Internet Exploder or Chrome, or on any other PC (real or virtual). Not sure what's different today versus the hundreds (thousands?) of others days I've visited that site with this PC.

Language problem

Posted: Fri Aug 17, 2012 4:23 pm
by 1968leocomeeatabite
"In your browser's address bar, do you see "lang=spa" anywhere in the address (URL)? If so, that's an indication that somehow your LDS.org pages are being asked to be displayed in Spanish, so it's not surprising.
When I Sign in it looks like this: https://www.lds.org/church-calendar/?lang=eng#
So yes it is in English.
I can navigate anywhere around lds.org but when I Sign out it goes to Spanish. It looks like this.
https://www.lds.org/?lang=spa
I click on the earth and change it to English.
But every time I Sign out it will always go to Spanish.
https://www.lds.org/?lang=spa

Posted: Fri Aug 17, 2012 4:36 pm
by russellhltn
Mikerowaved wrote:I think there's a bigger underlying problem with the site. Starting earlier today, every time I go to lds.org with Firefox, it comes up in Russian. I can select English from the little "globe" icon, but the next time I visit, it goes back to Russian.

This only happens with Firefox on this particular computer. I don't experience this problem with either Internet Exploder or Chrome, or on any other PC (real or virtual). Not sure what's different today versus the hundreds (thousands?) of others days I've visited that site with this PC.


We've had language problems before. clearing the cache and cookies fixed it then. The fact it's one browser on one machine suggests the same fix.

Posted: Fri Aug 17, 2012 9:13 pm
by lajackson
Mikerowaved wrote:I think there's a bigger underlying problem with the site. Starting earlier today, every time I go to lds.org with Firefox, it comes up in Russian. I can select English from the little "globe" icon, but the next time I visit, it goes back to Russian.


Starting today, any time I sign out using the Name/Tools dropdown menu signout button, I am thrown to the lds.org page in Spanish. I have repeatedly duplicated this using three different computers, Firefox each time, and clearing the cache does nothing to help. I do enter the site in English each time, even if I do not clear the cache. There is just something happening when I signout.

Is FF missing something, or is something at the site not telling FF something?

Posted: Fri Aug 17, 2012 9:24 pm
by russellhltn
lajackson wrote:Starting today, any time I sign out using the Name/Tools dropdown menu signout button, I am thrown to the lds.org page in Spanish.


Confirmed. The signout link is

Code: Select all

https://www.lds.org/signinout/?lang=eng&signmeout
but the next page that loads is

Code: Select all

https://www.lds.org/?lang=spa


Even executing that code manually does the same thing. Something's wrong with the signout function. (I used IE9)

Posted: Fri Aug 17, 2012 9:32 pm
by lajackson
RussellHltn wrote:Confirmed. The signout link is

Code: Select all

https://www.lds.org/signinout/?lang=eng&signmeout
but the next page that loads is

Code: Select all

https://www.lds.org/?lang=spa


Even executing that code manually does the same thing. Something's wrong with the signout function. (I used IE9)


Ah, the nefarious link name is different for actual link coded error. I sent Feedback through the lds.org page. They will probably chuckle when they get it sometime in the future and have already fixed the problem.

Posted: Sun Aug 19, 2012 9:36 am
by barkeraj
Thanks to Mikerowaved for pointing me here. I've brought this up with LDS.org team, who are likely at church. It may take us a while to get to it, but it's officially on our radar now. Thanks for reporting it