LDS RSS Tech Feed Email URL challenges

Having a problem with the Forum, Wiki, Jira or other aspect of tech.lds.org? This is the place.
kccarsten-p40
New Member
Posts: 1
Joined: Sat Nov 22, 2008 10:39 am
Location: Danville, California, USA

LDS RSS Tech Feed Email URL challenges

Postby kccarsten-p40 » Sat Nov 22, 2008 10:49 am

I get the LDSTech Site RSS Feed and find that the reference URLs enclosed therein are generally not correct. For example, in the one titled "Church History Library Tagging Project " the URL appears as [font=Georgia](http://tech.lds.org/index.php?option=com_content task=view id=369 Itemid=1)Image at the bottom of the email. Note that the linked portion of it is not complete. In addition, even the full text of the link is incorrect. The correct link is http://tech.lds.org/index.php?option=com_content&task=view&id=369 with the "&" characters missing in the original link.[/font]
[font=Georgia][/font]
[font=Georgia]My email client is Outlook 2007[/font]
[font=Georgia][/font]
[font=Georgia]I wasn't sure where to send this suggestion to fix the email feed, so I posted it here.[/font]
[font=Georgia][/font]
[font=Georgia]Thanks[/font]

User avatar
garysturn
Senior Member
Posts: 608
Joined: Thu Feb 15, 2007 11:10 am
Location: Draper, Utah, USA
Contact:

Postby garysturn » Sat Nov 22, 2008 11:31 am

I see what you are saying, I am not the one to fix the problem, but here is more information. Below is the way the RSS feed appears in Google Reader. The heading contains the correct link, but at the bottom of the post the link shown in () is missing "&" symbols and has spaces. So if you copy the link from the bottom of the post and paste it into the address bar it does not work. If someone gets this post by email, they may not get the heading link.

[color="Navy"]Church History Library Tagging Project[/color]
By the summer of 2009, those with interest in LDS History will have greatly improved facilities in the form of a new Church History Library building currently under construction in downtown Salt Lake City at the corner of Main Street and North Temple. The site was dedicated on October 7, 2005 and the move is anticipated to begin in April of 2009. The new 230,000 square-foot, state-of-the art library will have two types of archival storage rooms. The ten main storage rooms will be kept at a specific temperature and humidity to preserve the archives. Two special rooms will be kept at minus four degrees Fahrenheit to protect color motion picture films, photographs, and records of special significance to the LDS Church. Read more. (http://tech.lds.org/index.php?option=com_content task=view id=369 Itemid=1)
Gary Turner
If you haven't already, please take a moment to review our new
Code of Conduct

User avatar
mkmurray
Senior Member
Posts: 3241
Joined: Tue Jan 23, 2007 9:56 pm
Location: Utah
Contact:

Postby mkmurray » Sat Nov 22, 2008 9:17 pm

GarysTurn wrote:I see what you are saying, I am not the one to fix the problem, but here is more information. Below is the way the RSS feed appears in Google Reader. The heading contains the correct link, but at the bottom of the post the link shown in () is missing "&" symbols and has spaces. So if you copy the link from the bottom of the post and paste it into the address bar it does not work. If someone gets this post by email, they may not get the heading link.

[color="Navy"]Church History Library Tagging Project[/color]
By the summer of 2009, those with interest in LDS History will have greatly improved facilities in the form of a new Church History Library building currently under construction in downtown Salt Lake City at the corner of Main Street and North Temple. The site was dedicated on October 7, 2005 and the move is anticipated to begin in April of 2009. The new 230,000 square-foot, state-of-the art library will have two types of archival storage rooms. The ten main storage rooms will be kept at a specific temperature and humidity to preserve the archives. Two special rooms will be kept at minus four degrees Fahrenheit to protect color motion picture films, photographs, and records of special significance to the LDS Church. Read more. (http://tech.lds.org/index.php?option=com_content task=view id=369 Itemid=1)

I wonder if it's an issue with ampersands (&) not getting correctly URL encoded or escaped? Then when the output is put to the RSS feed, it's gone.

User avatar
WelchTC
Senior Member
Posts: 2088
Joined: Wed Sep 06, 2006 7:51 am
Location: Kaysville, UT, USA
Contact:

Postby WelchTC » Mon Nov 24, 2008 8:58 am

Thanks. I'll see if we can get a fix for this. We are looking at changing our publication engine anyway.

Tom


Return to “Help with tech.lds.org”

Who is online

Users browsing this forum: No registered users and 1 guest