Unexplained failures with the new portal

Conversations around originating a webcast for conference, including cameras and mixers.
justincy
Member
Posts: 54
Joined: Sat Dec 27, 2008 10:16 am
Location: United States

Unexplained failures with the new portal

Postby justincy » Fri Apr 24, 2015 4:04 pm

We had an interesting problem during a test Wednesday night with a VidiU device and the new portal. When attempting start the broadcast the VidiU would show a "RTMP Publish Failed" error message. We had never seen that before.

We first thought it was the network since we were using a mobile hotspot but 1) I was able to broadcast on the same network via my laptop and 2) we got the same error message on the church's network which has worked before.

After an hour of troubleshooting we finally just schedule a new test to get a different server and everything worked flawlessly that time.

We previously had an unusual test failure where the portal showed it was receiving our broadcast at the desired bitrate (slightly above) and that the encoder was in good health but no receiving sites were able to connect. We never were able to figure what caused the problem, nor have we been able to replicate the problem.

Has anybody else experienced problems like this? It concerns me greatly that everything might appear well but just not work with the only solution being to schedule another event.

While scheduling the real live broadcast for Stake Conference this Sunday, I was only able to find one region in the US that had any available resources for us. What happens if, on Sunday, we run into this same problem but we can't schedule an event last-minute because there are no available resources?

No bueno.

rolandc
Member
Posts: 257
Joined: Tue May 15, 2012 7:20 pm

Re: Unexplained failures with the new portal

Postby rolandc » Fri Apr 24, 2015 5:21 pm

The old system still works

you could also rent some rtmp server time on wowza or other,,,,50 - 75 dollars
Roland

User avatar
johnshaw
Senior Member
Posts: 1839
Joined: Fri Jan 19, 2007 1:55 pm
Location: Syracuse, UT

Re: Unexplained failures with the new portal

Postby johnshaw » Fri Apr 24, 2015 6:01 pm

Last Minute Events And Church Azure Cloud relationship do not go hand in hand. The very point of the new cloud system is so the church doesn't have to spend the $$$$$ on servers and infrastructure that sit there idle for 6 days a week and are at full capacity for only a day. Moving to a cloud architecture allows the church to pay only for the single day at full capacity to a cloud provider.

Our leaders need to understand this is how it works now.
“A long habit of not thinking a thing wrong, gives it a superficial appearance of being right, and raises at first a formidable outcry in defense of custom.”
― Thomas Paine, Common Sense

russellhltn
Community Administrator
Posts: 20775
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Unexplained failures with the new portal

Postby russellhltn » Fri Apr 24, 2015 6:51 pm

johnshaw wrote:Last Minute Events And Church Azure Cloud relationship do not go hand in hand.


Understood. But justincy is running into a problem with scheduled. He's having to work around by abandoning his scheduled server and doing a last-minute event. The problem isn't the leaders, but the scheduled system failing to work.
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

KOlive43
New Member
Posts: 3
Joined: Sun Dec 14, 2014 4:20 pm

Re: Unexplained failures with the new portal

Postby KOlive43 » Sat Mar 19, 2016 3:20 pm

One thing that I do know which can cause this error is if your TERADEK's RTMP settings don't match those of the scheduled event. You can fix this by doing the following:

First, schedule the event in portal.ldswebcast.org (if you haven't already).

While you're waiting on the "LDS Meetinghouse Webcast Event Details" page for the red box which reads, "Media server not ready. Do not start your encoder. Return here to verify server status." to turn into a green box which reads, "You may begin encoding now.", scroll down to the "Broadcast Info" section of that page and copy the whole "rtmp://..." link.

On the physical front of the TERADEK device, use the "MENU" button to find the current IP address of the TERADEK, like so:
- Push it to the right, to "BROADCAST SETTINGS";
- Push it down three times, to "NETWORK SETTINGS";
- Push it right to "NETWORK";
- Push it right while on "WIRED" or "WIFI", and you'll see the IP address (for example, 10.159.48.24); and
- Type that IP address into the address box of a browser on the same network and hit Enter, which should bring up your TERADEK's VidiU web interface.

Now that you're in the VidiU web interface;
- Click the "Settings" button at the top-right of the page;
- Click the big "Broadcast" button at the top-left;
- Open the "Platform" section;
- Paste the URL that you copied previously, from the "Event Details" page, into the RMTP Server URL box;
- Go back to the "Event Details" page where you scheduled the event and copy the "Stream Name";
- Back on the VidiU settings, paste the stream name into the "Stream" box;
- Click the green "Apply" button up at the top-right corner of the page;
- Click the "< Settings" button at the top-left corner of the page to go back; and
- Click the "Done" button at the top-left corner of the page, to return to your VidU home page.

Reload the "Event Details" page, and if the red box is now green, go back to the VidiU home page and click the big, round green and black button below the image to start the stream. This time, you shouldn't get the "RTMP Publish Failed" message on the front panel of the TERADEK device, and it should say "Starting" and then "Live".

rannthal
Church Employee
Church Employee
Posts: 92
Joined: Mon Jun 09, 2014 1:41 pm

Re: Unexplained failures with the new portal

Postby rannthal » Mon Mar 21, 2016 8:16 am

Let me point out that the original date of the first posting was April of last year. That time was close to when the new solution was first released, February of 2015. It has almost been an entire year since the first posting and there have been some major improvements since then.

If something like this continues to happen, please post, but if not, I would suggest not to bring up old issues and let them alone.

rolandc
Member
Posts: 257
Joined: Tue May 15, 2012 7:20 pm

Re: Unexplained failures with the new portal

Postby rolandc » Mon Mar 21, 2016 10:18 am

This happened to us this past Saturday the Vidiu page on my PC said "RTMP Publish Failed" after verifying all the correct broadcast settings a simple reboot of the Vidiu solved the problem.

Did not change anything after the reboot, it just worked, PERFECTLY.
Roland

User avatar
Biggles
Senior Member
Posts: 924
Joined: Tue May 27, 2008 4:14 am
Location: Watford, England

Re: Unexplained failures with the new portal

Postby Biggles » Mon Mar 21, 2016 10:37 am

rolandc wrote:This happened to us this past Saturday the Vidiu page on my PC said "RTMP Publish Failed" after verifying all the correct broadcast settings a simple reboot of the Vidiu solved the problem.

Did not change anything after the reboot, it just worked, PERFECTLY.

Out of curiosity, what version of firmware is the Vidiu using?

We have just had our Webcasting system installed and I'm hoping to play with it, during this week.

rannthal
Church Employee
Church Employee
Posts: 92
Joined: Mon Jun 09, 2014 1:41 pm

Re: Unexplained failures with the new portal

Postby rannthal » Tue Mar 22, 2016 1:28 pm

Update it to the latest version, 2.3.8

User avatar
Biggles
Senior Member
Posts: 924
Joined: Tue May 27, 2008 4:14 am
Location: Watford, England

Re: Unexplained failures with the new portal

Postby Biggles » Tue Mar 22, 2016 3:40 pm

rannthal wrote:Update it to the latest version, 2.3.8

Hence my question as to which version they are currently using. It would help to isolate a firmware issue, or some other problem.


Return to “Webcasting”

Who is online

Users browsing this forum: No registered users and 1 guest