Sony RS-422 control; finally working

Conversations around originating a webcast for conference, including cameras and mixers.
aclawson
Senior Member
Posts: 712
Joined: Fri Jan 19, 2007 6:28 pm
Location: Commerce Twp, MI

Sony RS-422 control; finally working

Postby aclawson » Sun Feb 01, 2015 12:20 pm

Finally got the remote camera control working - the problem was that the wires in the keystone had been reversed. The system is now set up so that any plain, regular, vanilla off the shelf telephone cord can be connected through a keystone jack in the wall and the RS-422/USB adapter.

Running cat 5 (or 6) from the camera to the control point:

Holding the Phoenix block with the screws facing you and the wires coming in from the left from top to bottom the wires as as follows:

---> wires coming in from this side

plugs into the camera --->

empty
empty
empty
empty
BROWN
ORANGE/WHITE
SOLID ORANGE
BLUE/WHITE
SOLID BLUE

On the RJ-11 keystone jack at the other end

1 (at the front): empty
2: ORANGE/WHITE
3: SOLID ORANGE
4: SOLID BLUE
5: BLUE/WHITE
6 (at the front): empty

Pins 1 and 6 are the slots closest to the front of the jack (where the cable plugs in).

The brown wire can be attached to any grounding point if necessary.

With the wires like this you can use any cord that would connect a telephone to the wall and the connections are correct. No special cables of any kind are needed.

jimbo3san
New Member
Posts: 10
Joined: Sat Feb 12, 2011 12:28 am
Location: Lehi, UT

Re: Sony RS-422 control; finally working

Postby jimbo3san » Mon Feb 02, 2015 4:24 pm

aclawson,

I feel your pain. We just finished another SC yesterday (2/1). I have been doing these for 6 years now and this was my 13th time doing this (2 per year). Over this time I have had my successes and many woes with RS232 and RS422. I have a few posts that discuss this topic on the forum.

I am planning on writing up a very plain and straight forward post so that anyone can do this too. I appreciate the number of hours it takes to get this to work, searching web posts and referring to anything that you can find to help, trial and error many, many times.

What I found regardless of what RS422 interface is used to make the connections is this (pin references are for Sony "D" Series PTZ camera connections):

From the RS422 interface device to the 1st camera (and only the 1st camera) in the chain connect:

Tx+ ---> Rx- (Pin 4)
Tx- ---> Rx+ (Pin 3)
Rx+ ---> Tx- (Pin 2)
Rx- ---> Tx+ (Pin 1)


Then from the 1st camera to the 2nd camera (and up to 7 cameras...daisy chained):

Tx+ (Pin 6) ---> Rx+ (Pin 3)
Tx- (Pin 7) ---> Rx- (Pin 4)
Rx+ (Pin 8) ---> Tx+ (Pin 1)
Rx- (Pin 9) ---> Tx- (Pin 2)

Once you know this you can then run the physical wiring as needed with most any tyoe of wire (LAN cable just works great) and everything is happy. Also, it is important to power cycle the cameras and ensure that they are set to "RS422" with dip switch 4 on the bottom...

Glad you figured it out. It gives you a sense of gratification when you finally do get it going.


-Jim B.
(Jimbo3san)

michaelfish
Member
Posts: 414
Joined: Sun May 10, 2009 3:44 pm
Location: Gilbert, AZ USA

Re: Sony RS-422 control; finally working

Postby michaelfish » Mon Feb 02, 2015 7:27 pm

ensure that they are set to "RS422" with dip switch 4 on the bottom...

The RS-232C/RS-422 switch is switch 3

The brown wire can be attached to any grounding point if necessary.

In my experience, the RS-422 connection must be grounded in order to keep the video clean. Any time the ground was lifted, there was terrible interference in the video.


Return to “Webcasting”

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest