Webcast - Error Adding video device

Conversations around originating a webcast for conference, including cameras and mixers.
matthewoxford
New Member
Posts: 2
Joined: Mon Jul 02, 2012 1:10 pm

Webcast - Error Adding video device

Postby matthewoxford » Mon Jul 02, 2012 1:12 pm

We are using the Meetinghouse Webcast software to broadcast our meetings to a member who is hospitalized. When I start the Webcast software and go to add a video device, I select the camera and get :

Error adding None with None

Clink the bottom for details and get:

[font="]Microsoft.Expression.Encoder.SystemErrorException: Cannot create device. The device may be in use by another program. ---> System.Runtime.InteropServices.COMException: Exception from HRESULT: 0x813A000D[/font]
at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
at System.Runtime.InteropServices.Marshal.ThrowExceptionForHR(Int32 errorCode)
at ThrowHRESULT(Int32 hr)
at MS.Internal.Expression.Encoder.Live.LiveEncode.CreateTimelineSegments()
at MS.Internal.Expression.Encoder.Live.LiveEncode.AddDeviceSource(LiveDevice videoDevice, LiveDevice audioDevice)
at Microsoft.Expression.Encoder.Live.LiveJob.AddDeviceSource(EncoderDevice videoDevice, EncoderDevice audioDevice)
--- End of inner exception stack trace ---
at Microsoft.Expression.Encoder.Live.LiveJob.AddDeviceSource(EncoderDevice videoDevice, EncoderDevice audioDevice)
at Lds.CM.MeetinghouseWebcast.UI.ViewModels.DeviceSourceViewModel.ModifyDeviceSource()

I have also loaded the webcast software to my home computer to see if I would get the same results but it works just fine.

Any thoughts you might be able to give would be a great help

User avatar
Mikerowaved
Community Moderators
Posts: 3131
Joined: Sun Dec 23, 2007 12:56 am
Location: Layton, UT

Postby Mikerowaved » Mon Jul 02, 2012 3:52 pm

Can you please describe a bit more your computer hardware, operating system, and video device you are trying to add.

Anything else running that might take charge of the camera, such a Skype? Have you tried adding the camera right after a fresh reboot?
So we can better help you, please edit your Profile to include your general location.

matthewoxford
New Member
Posts: 2
Joined: Mon Jul 02, 2012 1:10 pm

Postby matthewoxford » Mon Jul 02, 2012 4:07 pm

I have a Dell Inspiron 1545, with Windows 7 Home Premium. Pentium dual-core CPU T45000 @ 2.30 Ghz 2.30 Ghz. 2 GB Ram, 64 bit operating system

I'm trying to use a Logitech 9000 USB camera/mic.

I can get the mic to load as an audio device on this system with out problems. But when you select the video as a input device I get the error listed below.

I cant find anything else taking charge of the camera. I have tried restarting the computer and immediately trying add the device.

I have uninstalled the Logitech software, uninstalled and reinstalled the camera drivers, uninstalled and reinstalled webcast & Microsoft expression encoder. Updated USB and video card drivers.

I can get this camera to load on two other computers just fine.

russellhltn
Community Administrator
Posts: 20743
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Mon Jul 02, 2012 4:28 pm

You might want to try another USB port.

You might also look to see what IRQs are assigned to what. I'm old-school from back when we had to make sure all hardware had it's own IRQ. These days, drivers should play together and allow IRQ sharing. But not all drivers play nicely. Moving the affected device to another IRQ can help.
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

ksolsen
Church Employee
Church Employee
Posts: 115
Joined: Tue May 24, 2011 3:06 pm

Postby ksolsen » Mon Jul 16, 2012 1:46 pm

I don't know if this is relevant for you, but in our experience (for some reason), Microsoft Expression Encoder (which of course is really the software doing all of the heavy lifting behind Meetinghouse Webcast Software 3.0) does not do well with USB hubs, whether they are powered or not. Even a docking station for a laptop (my scenario) is considered a USB hub. So I always get errors unless I plug my webcam directly into a USB port on the laptop - won't work if it's going into the docking station.
Kurt Olsen - Product Manager at Church HQ for Digital Presentation (Personal Video Conferencing, Meetinghouse Webcast, Conference Rooms, Video Conference Endpoints, Meetinghouse Digital Content)


Return to “Webcasting”

Who is online

Users browsing this forum: No registered users and 1 guest