Printing works but not from MLS

Discussions around using and interfacing with the Church MLS program.
gbogdan7
New Member
Posts: 5
Joined: Fri Jan 07, 2011 1:37 pm

Printing works but not from MLS

Postby gbogdan7 » Fri Jan 07, 2011 1:40 pm

Our printer works and I can print things from the the desktop but when I try to print from MLS I am getting an error message with the "frown face". I tried rebooting the computer and the printer, several times, and no luck. The odd thing is that that printer is printing everything else from the computer fine. Anything that I try to print from MLS is problematic.

User avatar
aebrown
Community Administrator
Posts: 14690
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Postby aebrown » Fri Jan 07, 2011 2:14 pm

gbogdan7 wrote:Our printer works and I can print things from the the desktop but when I try to print from MLS I am getting an error message with the "frown face". I tried rebooting the computer and the printer, several times, and no luck. The odd thing is that that printer is printing everything else from the computer fine. Anything that I try to print from MLS is problematic.


Here are some things to clarify or try:

  1. So when exactly do you get the error message in MLS? Is it immediately upon pressing the Print button (the button that appears at the bottom left corner of most)?
  2. Is a printer defined in Windows as your Default Printer?
  3. Does Print Preview work?
  4. Do you have a PDF printer (such as CutePDF) installed? If so, can you select that printer from the MLS Print dialog? Can you then print to the PDF printer?
  5. You might try editing the print.properties file (found in C:\ProgramData\LDS Church\MLS\data for Windows 7 or in C:\Program Files\LDS Church\MLS for Windows XP). There should be a line "PrinterName=" followed by the name of the printer selected for MLS. If that is blank, perhaps filling in the precise name of your default printer in Windows might help. Do this step when MLS is not running.
Questions that can benefit the larger community should be asked in a public forum, not a private message.

jdlessley
Community Moderators
Posts: 6526
Joined: Sun Mar 16, 2008 11:30 pm
Location: USA, TX

Postby jdlessley » Fri Jan 07, 2011 2:52 pm

I would add two more questions.
  1. Does your printer name appear in the "Name" drop-down listbox of the Print dialog box before you click OK?
  2. Is your printer even listed in the "Name" drop-down listbox for all available printers and print drivers?
JD Lessley
Have you tried finding your answer on the LDS.org Help Center page or the LDSTech wiki?

gbogdan7
New Member
Posts: 5
Joined: Fri Jan 07, 2011 1:37 pm

Postby gbogdan7 » Fri Jan 07, 2011 3:52 pm

WOW, this Forum is great, it was the print.properties file, THANKS!
Works great now.

shrtxus
New Member
Posts: 2
Joined: Fri Mar 30, 2012 7:06 am

Postby shrtxus » Wed Oct 17, 2012 7:57 pm

Sorry to resurrect this old topic, but I am having an issue very similar. I have attempted every single suggestion listed above except for the print.properties fix, as this file does not appear to exist anywhere within the MLS group of folders. Whenever I attempt to print a check, I either get an error from MLS (frowny face) or I get an error from the printer and the check does not print. When this happens, I cannot print anything else until I restart the printer. Other programs print without problems, and I can print membership records from MLS as well. (I have made sure that I am printing to the correct printer) Any ideas? The Stake IT clerk is out of town, and I'd like to get this problem fixed before Sunday.

russellhltn
Community Administrator
Posts: 20750
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Wed Oct 17, 2012 8:21 pm

Has anything recently changed? It sounds like things used to work, but now they don't. MLS just rolled out to some units, so it's possible there's a check printing bug. What model is your printer? Has that been recently changed?
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

lajackson
Community Moderators
Posts: 6137
Joined: Mon Mar 17, 2008 9:27 pm
Location: US

Postby lajackson » Wed Oct 17, 2012 8:44 pm

And have you just upgraded to version 3.5?

shrtxus
New Member
Posts: 2
Joined: Fri Mar 30, 2012 7:06 am

Postby shrtxus » Thu Oct 18, 2012 12:39 pm

Still on 3.4.3, same printer, no recent changes I can recall, simply stopped working on Sunday afternoon. Today, I attempted to print other documents but was not able to do so until after restarting the printer. I wonder if the problem is with the PC or printer and MLS check is just the trigger. The printer is a HP Laserjet 1200 with about 60k pages printed.

russellhltn
Community Administrator
Posts: 20750
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Thu Oct 18, 2012 12:43 pm

You might want to see what printer driver is installed. You may have more then one "printer" in Windows for the same physical printer. PCL5, PCL6 and Postscript are not unusual for HP printers. You may want to try one of the others.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

jdlessley
Community Moderators
Posts: 6526
Joined: Sun Mar 16, 2008 11:30 pm
Location: USA, TX

Postby jdlessley » Thu Oct 18, 2012 12:48 pm

Is it possible the printer's driver was updated just before the problem began? If it was not updated then try updating the driver. Also try uninstalling and reinstalling the print driver. This would resolve any driver corruption issues as well as some hard drive issues (bad sector).
JD Lessley
Have you tried finding your answer on the LDS.org Help Center page or the LDSTech wiki?


Return to “MLS Support, Help, and Feedback”

Who is online

Users browsing this forum: i2rtw and 1 guest