MLS 3.2.3 won't start

Discussions around using and interfacing with the Church MLS program.
psnarula
Member
Posts: 92
Joined: Mon Dec 01, 2008 7:11 pm
Location: Wiesbaden, Germany

MLS 3.2.3 won't start

Postby psnarula » Sun Oct 10, 2010 10:43 pm

I did a send/receive on Sunday (yesterday) and it auto-downloaded MLS 3.2.3 (ahead of the transition to CUBS in two weeks) and told me to reboot. After the reboot, I got a blue screen of death. I rebooted again and this time avoided the BSOD but MLS would not start (double-clicking on the icon had no effect -- no splash screen, no java process got kicked off in Task Viewer, nothing...).

So I downloaded the full MLS 3.2.3 installer from mls.lds.org (101MB) and figured I could install it on top of what was already there. That didn't work -- the installer said that the version already installed was newer than what was trying to be installed.

So then I tried to uninstall the existing MLS so I could come back and reinstall the full MLS download. That didn't work because the MLS uninstall process hung during the last step (deleting registry keys). I found some information on the clerk wiki about how to completely uninstall MLS:
https://tech.lds.org/wiki/index.php/MLS_installation_and_repair#Uninstall

I tried many of the suggestions there -- deleting Afaria, UDX, and Java directories but nothing helped.

So now the clerk computer has no working version of MLS installed on it. If I could get the existing MLS to uninstall, I expect I could reinstall MLS from the full download. Any ideas?

I'm on vacation with my family this week (we leave this morning and return Thursday night). I was going to go to the church on Friday night to submit the quarterly report but now it's looking like that isn't going to happen.

I wonder if it's possible to just reload this computer with a clean installation of Windows XP. Does the stake keep the software I would need to make this happen? If I had a clean install, I could install MLS and presumably things would be happy again...

Who can help me with these problems? Stake Clerk? STS?

We had several tithing donations to process after church and were unable to do it in MLS. I just made a spreadsheet to record the donation information and we included that (along with a note explaining the situation) with the usual stuff that gets mailed to SLC. Not sure how this is going to get resolved. Mail from Germany to SLC usually takes about a week so if might be able to get these entered into the MLS before the letter is received in Utah. Also, the RS President needs to get reimbursed for food purchased from Fast Offering funds but I can't get in to MLS to process the check...

russellhltn
Community Administrator
Posts: 20764
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Sun Oct 10, 2010 11:20 pm

I spun this off as a new thread, since it's separate from the actual upgrade.

psnarula wrote:I wonder if it's possible to just reload this computer with a clean installation of Windows XP. Does the stake keep the software I would need to make this happen?


They might. Then again, they might have left your ward with all the install media.

psnarula wrote:Who can help me with these problems? Stake Clerk? STS?


STS. Ask the stake clerk if the STS can't or won't help.

psnarula wrote:Also, the RS President needs to get reimbursed for food purchased from Fast Offering funds but I can't get in to MLS to process the check...


Emergency Check Writing Procedures
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

User avatar
aebrown
Community Administrator
Posts: 14693
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Postby aebrown » Mon Oct 11, 2010 5:06 am

psnarula wrote:I wonder if it's possible to just reload this computer with a clean installation of Windows XP. Does the stake keep the software I would need to make this happen? If I had a clean install, I could install MLS and presumably things would be happy again...


If the computer was originally set up using the Desktop 5.5 image, then a much simpler option would be to restore the saved system image, as described in this post.
Questions that can benefit the larger community should be asked in a public forum, not a private message.

crislapi
Senior Member
Posts: 1265
Joined: Mon Jul 07, 2008 3:05 pm
Location: USA

Postby crislapi » Mon Oct 11, 2010 7:41 am

I had a second ward computer do virtually the same thing yesterday. The patch downloaded, installed and prompted for a reboot. The unit finished their finances for the day but forgot to restart. When I went to shut down, there was a windows update so I figured I might as well get that, too. I selected "Install updates and shutdown".

Yeah, you'd think I'd have remembered. No BSOD this time, but MLS would not start up after the reboot. I'd get the splash screen and then nothing. Downloading the MLS 3.2.3 installer and installing over the existing install fixed the install.

stanstrad
New Member
Posts: 21
Joined: Tue Apr 22, 2008 8:31 pm
Location: Mesa, AZ USA

2 Computers in the stake with similar issue

Postby stanstrad » Mon Oct 11, 2010 12:34 pm

I had 2 computers in the stake with similar issue. The patch downloaded, installed. MLS would not start up after the reboot. Would flash the splash screen and then disappear and no MLS.
Downloaded the MLS 3.2.3 and installed over the existing install fixed the problem.

crislapi
Senior Member
Posts: 1265
Joined: Mon Jul 07, 2008 3:05 pm
Location: USA

Postby crislapi » Mon Oct 11, 2010 11:46 pm

Here's a thought. If you do not have Desktop 5.5 installed, try a system restore to a date prior to downloading the patch. That should return MLS to its pre-update mode, undoing whatever the current glitch is. If the restore works, then I guess your 2 options are to uninstall the previous version first or just install 3.2.3 over 3.2.2. I guess I'd be worried about running into the same bug when trying to uninstall, so I'd probably go with running the installer over the previous version.

I believe Desktop 5.5 has disabled the system restore feature, so this won't work if you have it. I'd recommend this before you try a complete system reinstall. Less time consuming. And if it doesn't work, you still have that as an option.

crislapi
Senior Member
Posts: 1265
Joined: Mon Jul 07, 2008 3:05 pm
Location: USA

Postby crislapi » Mon Oct 11, 2010 11:51 pm

psnarula wrote:the installer said that the version already installed was newer than what was trying to be installed.


This is the line that bothers me the most. You do not get this error if you run the installer of the same MLS version currently installed on your computer. Somehow you computer has gotten confused into thinking it is a later version of MLS than it is. As for how that happened, I have no idea.

russellhltn
Community Administrator
Posts: 20764
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Mon Oct 11, 2010 11:53 pm

crislapi wrote:This is the line that bothers me the most.


I have to agree with that. It makes me wonder what's going on.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

User avatar
mfmohlma
Senior Member
Posts: 784
Joined: Thu Feb 28, 2008 5:45 pm
Location: Hillsboro, OR

Postby mfmohlma » Tue Oct 12, 2010 11:31 am

RussellHltn wrote:I have to agree with that. It makes me wonder what's going on.


Sometimes it just happens. Bits get flipped - cosmic rays, et. al.

psnarula
Member
Posts: 92
Joined: Mon Dec 01, 2008 7:11 pm
Location: Wiesbaden, Germany

Postby psnarula » Fri Oct 15, 2010 2:34 am

Just got back last night from vacation with the family at Disneyland Paris. This issue still needs to be resolved. I'm thinking that somewhere there is a registry key that makes the installer think that a newer version is installed. Maybe I'll use Process Monitor to see which registry keys the installer is accessing. I might be able to fix this problem by just deleting a few rogue registry keys...

Not sure what the situation is with the STS. Maybe I'll call him tomorrow if I can't fix this myself tonight.


Return to “MLS Support, Help, and Feedback”

Who is online

Users browsing this forum: No registered users and 1 guest