MLS won't upgrade to 3.2. Related to transmission issue & missing statements?

Discussions around using and interfacing with the Church MLS program.
crislapi
Senior Member
Posts: 1265
Joined: Mon Jul 07, 2008 3:05 pm
Location: USA

MLS won't upgrade to 3.2. Related to transmission issue & missing statements?

Postby crislapi » Mon Jul 05, 2010 10:27 am

Yesterday I discovered a couple interesting things happening on 2 computers in the stake. I have previously posted that 2 of the computers in my stake have not automatically updated to MLS 3.2. As of yesterday, they are the only two that have not. I find it interesting that these two computers are also the only two that are also experiencing the send/receive glitch I commented on here (confirmation for financial transactions does not occur immediately). Finally, I went around yesterday helping clerks in all the units get ready for the upcoming audits (yes, it's almost time again) and realized that, on these same two computers, the CUFS stopped automatically downloading after March, resulting in the wards not being able to complete their reconciliations. We could request April and May's statements but it would not let us request June yet.

My question is are these all related? It would not surprise me in MLS will not automatically update unless everything is up to date (reconciliations, for example). However, what would explain why the CUFS stopped being sent to the units? Is it also related to the send/receive glitch? Could that lack of communication back from the HQ server mean CHQ can't send down the CUFS as well as the patches for MLS 3.2?

I tried sending/receiving about 20 times yesterday with no luck. I also tried going through both the modem (dial up) and the internet. No luck.

I realize I can manually download 3.2 and install it, but I'd like to understand what may be causing this glitch and fix it. Any thoughts?

russellhltn
Community Administrator
Posts: 20762
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Mon Jul 05, 2010 11:28 am

Some time ago, I had one unit where the version of MLS was old. Upon researching, I found they hadn't rebooted their computer in a couple of weeks. Once I rebooted, the MLS updated without doing a send/receive. (They are on dial-up).
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

User avatar
aebrown
Community Administrator
Posts: 14693
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Postby aebrown » Mon Jul 05, 2010 11:51 am

crislapi wrote:I find it interesting that these two computers are also the only two that are also experiencing the send/receive glitch I commented on here (confirmation for financial transactions does not occur immediately).


Those issues certainly seem to be related. If there are difficulties in receiving information during transmissions, then it makes sense that patches might not come down properly.

crislapi wrote:the CUFS stopped automatically downloading after March, resulting in the wards not being able to complete their reconciliations. We could request April and May's statements but it would not let us request June yet.


I'd be a bit nervous about financial clerks who haven't figured out until July that April's statement is not available. But June's statement can be requested now (my June statement was automatically downloaded today).

crislapi wrote:Finally, I went around yesterday helping clerks in all the units get ready for the upcoming audits (yes, it's almost time again) and realized that, on these same two computers, the CUFS stopped automatically downloading after March, resulting in the wards not being able to complete their reconciliations. We could request April and May's statements but it would not let us request June yet.

My question is are these all related? It would not surprise me in MLS will not automatically update unless everything is up to date (reconciliations, for example). However, what would explain why the CUFS stopped being sent to the units? Is it also related to the send/receive glitch? Could that lack of communication back from the HQ server mean CHQ can't send down the CUFS as well as the patches for MLS 3.2?

I tried sending/receiving about 20 times yesterday with no luck. I also tried going through both the modem (dial up) and the internet. No luck.

I realize I can manually download 3.2 and install it, but I'd like to understand what may be causing this glitch and fix it. Any thoughts?


It sure sounds like these issues are related, since they are all related to data coming down to MLS during transmissions. In any case, since you have been told that MLS 3.2 fixes the transmission problem, I would recommend that you manually install MLS 3.2 as soon as possible. I don't see any reason to try to "understand what may be causing this glitch" when there is an acknowledged bug in this area that is reportedly fixed in MLS 3.2. Install the upgrade, and if the problem no longer occurs, it seems reasonable to conclude that it was indeed a bug in MLS 3.1.5.
Questions that can benefit the larger community should be asked in a public forum, not a private message.

crislapi
Senior Member
Posts: 1265
Joined: Mon Jul 07, 2008 3:05 pm
Location: USA

Postby crislapi » Mon Jul 05, 2010 12:23 pm

RussellHltn wrote:Some time ago, I had one unit where the version of MLS was old. Upon researching, I found they hadn't rebooted their computer in a couple of weeks. Once I rebooted, the MLS updated without doing a send/receive. (They are on dial-up).


I've restarted their computer several times. Unfortunately, that didn't fix it.

Alan_Brown wrote: But June's statement can be requested now.


It actually can't - I did try. MLS gives an error message saying it can't be requested until at least the 15th of the month following the statements (July 15 for June's)

User avatar
aebrown
Community Administrator
Posts: 14693
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Postby aebrown » Mon Jul 05, 2010 7:00 pm

crislapi wrote:It actually can't - I did try. MLS gives an error message saying it can't be requested until at least the 15th of the month following the statements (July 15 for June's)


Interesting that they don't allow you to request a statement, even after the statements have been automatically sent. I guess I made a bad assumption. But since they have to catch up a couple of months, it's probably not that big of a deal to wait 10 more days.
Questions that can benefit the larger community should be asked in a public forum, not a private message.

User avatar
mfmohlma
Senior Member
Posts: 784
Joined: Thu Feb 28, 2008 5:45 pm
Location: Hillsboro, OR

Postby mfmohlma » Tue Jul 06, 2010 10:01 am

I was having the exact same bugs. I'd suggest just giving support a call and having them email (or snail-mail) the statements to the bishop. Before 3.2, I could "see" the statements in the send/receive queue (Help->Show Send/Receive Status), but they were never actually downloaded. I don't know if my system would have auto-updated, because I downloaded the full install as soon as it became available. Even after I did, April and May never did get downloaded. I haven't checked yet this month for June's statement.

...Looking forward to CUBS... :)

crislapi
Senior Member
Posts: 1265
Joined: Mon Jul 07, 2008 3:05 pm
Location: USA

Postby crislapi » Wed Jul 07, 2010 12:57 pm

Ok, to close out this discussion, I just called the GHD. The issue about not receiving confirmation on financial transactions and not receiving CUFS since March are both related to the known bug in 3.1.5. Updating to 3.2 will fix this. Once done, the statements should automatically download on the first send/receive. I'll test that and, if it doesn't, will comment.

Issue two: These computers did not accept the patch to 3.2 is because they have partial versions of MLS. Another way, there are some modules of MLS on the computer that are from earlier versions of MLS (somehow the earlier version of MLS was never updgraded completely to 3.1.5). Because of this, they were ineligible to receive the patch to 3.2. The only way to upgrade them is to manually install 3.2. I'll be doing that tonight.

crislapi
Senior Member
Posts: 1265
Joined: Mon Jul 07, 2008 3:05 pm
Location: USA

Postby crislapi » Thu Jul 08, 2010 9:29 am

crislapi wrote:Once done, the statements should automatically download on the first send/receive. I'll test that and, if it doesn't, will comment.


The only statement that automatically downloaded was April. I called an analyst (GHD) who confirmed that May and June were not queued up either. Contrary to what I was told the first time (shocker), this analyst said the missing statements would still have to be requested.

Installing 3.2 only took about 5 minutes, however.


Return to “MLS Support, Help, and Feedback”

Who is online

Users browsing this forum: No registered users and 1 guest