Best way to restore MLS data

Discussions around using and interfacing with the Church MLS program.
harjon
New Member
Posts: 17
Joined: Mon Jul 20, 2009 9:56 am
Location: USA

Best way to restore MLS data

Postby harjon » Sat Jan 23, 2010 8:44 am

Hello everyone. I've just re-imaged an Optiplex 740 because the computer wouldn't boot into Windows. I've installed everything on it including the latest version of MLS. Before re-imaging the system I removed the hard drive from the PC, hooked it up to an external USB hard drive adapter and copied the MLS folder (and some other data) from the hard drive. This means I have a current copy of the ward's MLS folder/data. What is the best way to restore it onto the newly re-imaged drive? Copy the MLS folder entirely or just go into MLS and do a restore using the latest backup file?

jdlessley
Community Moderators
Posts: 6527
Joined: Sun Mar 16, 2008 11:30 pm
Location: USA, TX

Postby jdlessley » Sat Jan 23, 2010 9:28 am

Thrasonic wrote:What is the best way to restore it onto the newly re-imaged drive? Copy the MLS folder entirely or just go into MLS and do a restore using the latest backup file?
Just restore the database using the latest backup - it is the safest method. You won't miss anything that way. Be sure to copy the Dialer.properties file from the old C:\Program Files\LDS Church\MLS folder to the same folder on the reimaged drive if you did not enter the dialer number during the MLS setup. All should be well.
JD Lessley
Have you tried finding your answer on the LDS.org Help Center page or the LDSTech wiki?

russellhltn
Community Administrator
Posts: 20779
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Sat Jan 23, 2010 11:16 am

Just as a note, you're likely to get a "security error" on Send/Receive. Not much you can do about that except call CHQ on Monday for a security reset.
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

harjon
New Member
Posts: 17
Joined: Mon Jul 20, 2009 9:56 am
Location: USA

Postby harjon » Sat Jan 23, 2010 11:31 am

Thanks for the quick responses. I figured it would be fine importing or restoring from the last backup but wanted to be sure. And yes, I copied the dialer.properties over, but admittedly would have forgotten to do so if I hadn't first read the official church instructions for re-doing a PC.

About the security error or inability to complete a send/receive, I realized this would happen last night and called SLC at 7 pm their time but it was too late. I just missed them. So I'll have to call first thing Monday a.m. to have them "reset" this ward's account for send/receive. I informed the clerk's last night about this snafu and told them to be prepared to not be able to send/receive Sunday.

Thanks again.


Return to “MLS Support, Help, and Feedback”

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest