MLS 3 keeps downloading to our computer

Discussions around using and interfacing with the Church MLS program.
regoarrarr
New Member
Posts: 8
Joined: Mon Dec 01, 2008 5:40 am
Location: Cincinnati, Ohio, USA

MLS 3 keeps downloading to our computer

Postby regoarrarr » Mon Jul 13, 2009 6:39 am

So, I read a few weeks ago that somehow more units than were intended got MLS 3.0 a bit early. I think that our ward was one of those units.

But for the past 5 weeks, every Sunday morning when I boot up the computer and start MLS, it says that it is downloading version 3.0 and that I will need to reboot.

By all appearances, MLS 3.0 appeared to work the first time (at least according to the version displayed in MLS).

So is this normal? Are there just different patches / minor versions that are being downloaded this week?

Or something else?

User avatar
mkmurray
Senior Member
Posts: 3241
Joined: Tue Jan 23, 2007 9:56 pm
Location: Utah
Contact:

Postby mkmurray » Mon Jul 13, 2009 7:21 am

regoarrarr wrote:So, I read a few weeks ago that somehow more units than were intended got MLS 3.0 a bit early. I think that our ward was one of those units.

But for the past 5 weeks, every Sunday morning when I boot up the computer and start MLS, it says that it is downloading version 3.0 and that I will need to reboot.

By all appearances, MLS 3.0 appeared to work the first time (at least according to the version displayed in MLS).

So is this normal? Are there just different patches / minor versions that are being downloaded this week?

Or something else?

Well there has been a new version of MLS just about every week (if you are on the beta program). Perhaps because of the mistaken first beta release, the Church decided to send down the rest of the betas to everyone as well?

Either way, this last week was the official non-beta release of MLS 3.0. I would hope your install of MLS would stop updating for a while now. :)
Many questions are already answered on the LDSTech wiki. Check it out!

User avatar
aebrown
Community Administrator
Posts: 14693
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Postby aebrown » Mon Jul 13, 2009 7:51 am

regoarrarr wrote:So is this normal? Are there just different patches / minor versions that are being downloaded this week?

Or something else?


The most likely explanation is what mkmurray said -- there have been 4 updates. But not 5. Perhaps it just seems to be that much, but there was just beta 5 (June 12), beta 6 (June 19), beta 7 (June 26), and then the final release this weekend (July 10). There was no update last week.

I did have a case with one ward in my stake where MLS didn't seem to recognize that it had been updated, so it kept trying to apply the same update on each Send/Receive.

To see if that might be happening, pay attention to the build number (which is available on the bottom of the login screen, or on Help > About after you have logged in). You should now be on build 15843, dated 10 July 2009. If you do an upgrade and you're still on that same build, then probably have the same issue.

If that is the case, have your stake technology specialist install the full version of MLS 3.0. In my case, that cleared up the problem.

regoarrarr
New Member
Posts: 8
Joined: Mon Dec 01, 2008 5:40 am
Location: Cincinnati, Ohio, USA

Postby regoarrarr » Mon Jul 13, 2009 7:51 am

Me too. Thanks for the info

crislapi
Senior Member
Posts: 1265
Joined: Mon Jul 07, 2008 3:05 pm
Location: USA

Postby crislapi » Mon Jul 13, 2009 1:29 pm

regoarrarr wrote:But for the past 5 weeks, every Sunday morning when I boot up the computer and start MLS, it says that it is downloading version 3.0 and that I will need to reboot.


Normal? That's subjective... It all depends what you consider normal for MLS!

Anyway, it occurred in our wards as well. Even if they transmitted twice in 10 minutes, both times they received the prompt that a new version of MLS was being downloaded. I know I dealt with it one Sunday 4 times on the stake computers. I have a hard time believing there were that many beta versions waiting for incremental install. I instead think that somehow the system wasn't recognizing that we had downloaded and installed the download already so it was locked in perpetual download mode.

Of course, I'll admit I did not pay attention to build numbers. Just wanted to let you know you weren't going crazy.

User avatar
aebrown
Community Administrator
Posts: 14693
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Postby aebrown » Mon Jul 13, 2009 1:40 pm

crislapi wrote:Anyway, it occurred in our wards as well. Even if they transmitted twice in 10 minutes, both times they received the prompt that a new version of MLS was being downloaded.


Did you reboot between those two transmissions? If you get an MLS update downloaded, but then didn't reboot and did another Send/Receive, you would get the update downloaded again. That's one of the reasons why MLS gives you multiple strong warnings that you need to reboot, and you should not delay the reboot process.

User avatar
mkmurray
Senior Member
Posts: 3241
Joined: Tue Jan 23, 2007 9:56 pm
Location: Utah
Contact:

Postby mkmurray » Mon Jul 13, 2009 1:43 pm

Alan_Brown wrote:Did you reboot between those two transmissions? If you get an MLS update downloaded, but then didn't reboot and did another Send/Receive, you would get the update downloaded again. That's one of the reasons why MLS gives you multiple strong warnings that you need to reboot, and you should not delay the reboot process.

I realize you are responding to crislapi, but I actually think many of you guys are misinterpreting regoarrarr's original post, which does not state anything about getting MLS updates on each Send/Receive. He only said that "for the past 5 weeks, every Sunday morning" he has been getting the notification of a new version of MLS.

This is (mostly) consistent with the Church sending down a new beta nearly every week for the last month or so.
Many questions are already answered on the LDSTech wiki. Check it out!

crislapi
Senior Member
Posts: 1265
Joined: Mon Jul 07, 2008 3:05 pm
Location: USA

Postby crislapi » Mon Jul 13, 2009 1:53 pm

Alan_Brown wrote:Did you reboot between those two transmissions?


Sorry, I meant to include that. Yes, we rebooted in between (the first few times at least).

mkmurray wrote:He only said that "for the past 5 weeks, every Sunday morning" he has been getting the notification of a new version of MLS.


That's what I get for reading quickly - I read what I wanted to hear (if you can actually hear what you read...). Yeah, the once a week update since the accidental release of the beta wouldn't surprise me.

User avatar
aebrown
Community Administrator
Posts: 14693
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Postby aebrown » Mon Jul 13, 2009 2:01 pm

mkmurray wrote:Well there has been a new version of MLS just about every week (if you are on the beta program). Perhaps because of the mistaken first beta release, the Church decided to send down the rest of the betas to everyone as well?


That's not a "perhaps" -- it is well documented that once you get a beta version, you will then get every update through the final release. That only makes sense, since there's no reasonable way to go back to the previous version once your database has been upgraded -- you might as well get the bug fixes along the way.

mkmurray wrote:... I actually think many of you guys are misinterpreting regoarrarr's original post, which does not state anything about getting MLS updates on each Send/Receive. He only said that "for the past 5 weeks, every Sunday morning" he has been getting the notification of a new version of MLS.


Since he described an update on every Sunday, when there was actually no update last week, I and others have simply been responding to a potential explanation for that behavior. Your explanation does not cover that part of the scenario, but I believe the most likely explanation is that regoarrarr was exaggerating slightly, and indeed your explanation is correct and it was just the 4 MLS 3.0 downloads (three betas and the final) that were downloaded.

User avatar
mkmurray
Senior Member
Posts: 3241
Joined: Tue Jan 23, 2007 9:56 pm
Location: Utah
Contact:

Postby mkmurray » Mon Jul 13, 2009 2:40 pm

Alan_Brown wrote:Since he described an update on every Sunday, when there was actually no update last week, I and others have simply been responding to a potential explanation for that behavior. Your explanation does not cover that part of the scenario, but I believe the most likely explanation is that regoarrarr was exaggerating slightly, and indeed your explanation is correct and it was just the 4 MLS 3.0 downloads (three betas and the final) that were downloaded.

And to the credit of others, it could be his unit only does a Send/Receive every Sunday, in which the other explanation could be viable. It just doesn't seem as likely or the norm for a unit to only Send/Receive once a week.
Many questions are already answered on the LDSTech wiki. Check it out!


Return to “MLS Support, Help, and Feedback”

Who is online

Users browsing this forum: No registered users and 1 guest