Custom member fields

Discussions around using and interfacing with the Church MLS program.
tw.lbean
New Member
Posts: 17
Joined: Sat Nov 08, 2008 10:20 pm
Location: Vista, CA, USA

Custom member fields

Postby tw.lbean » Sat Nov 08, 2008 10:34 pm

We have several ward members who have specifically requested to not be contacted by the ward at all. I'd like to be able to create some custom reports that exclude these members for use by general ward members (e.g. telephone directory).

I thought I could add a custom member field to these specific members called "Requested DNC". With that, I thought I'd be able to create a custom report with criteria "Requested DNC" "does not have value".

Unfortunately, this causes all members to be excluded, not just the ones without this field. This seems like a bug since I can change the criteria to "has a value" and get just the members with that field.

Am I doing something wrong? Is there a different way to accomplish this?

Triston.

User avatar
aebrown
Community Administrator
Posts: 14693
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Postby aebrown » Sun Nov 09, 2008 5:56 am

tw.lbean wrote:We have several ward members who have specifically requested to not be contacted by the ward at all. I'd like to be able to create some custom reports that exclude these members for use by general ward members (e.g. telephone directory).

I thought I could add a custom member field to these specific members called "Requested DNC". With that, I thought I'd be able to create a custom report with criteria "Requested DNC" "does not have value".

Unfortunately, this causes all members to be excluded, not just the ones without this field. This seems like a bug since I can change the criteria to "has a value" and get just the members with that field.

Am I doing something wrong? Is there a different way to accomplish this?

Triston.


I did a quick test, and it appears that the negative criteria ("has no value" and "does not contain") for Custom Reports are not working for any field, not just custom member fields. Any report I create that contains such criteria returns 0 members.

I'll do some more research later today, but perhaps some others can try this out and see if they get the same results.

UPDATE: Well, it's not quite as bad as I said for fields other than custom fields. The only odd thing is that if a field has no value, then the "does not contain" doesn't match such fields. That seems wrong to me. It is that oddity that led me to overgeneralize in my initial post. But "has no value" does work properly for regular fields.

However, it is looking like a bug to me that "has no value" for custom fields doesn't match.

tw.lbean
New Member
Posts: 17
Joined: Sat Nov 08, 2008 10:20 pm
Location: Vista, CA, USA

Postby tw.lbean » Sun Nov 09, 2008 5:21 pm

Thanks. That is definitely good news/bad news.

At least I'm not doing something really wrong. :)

User avatar
ericb
Member
Posts: 105
Joined: Fri Feb 23, 2007 8:51 am
Location: Vancouver USA

Postby ericb » Sun Nov 09, 2008 5:41 pm

Alan_Brown wrote: UPDATE: Well, it's not quite as bad as I said for fields other than custom fields. The only odd thing is that if a field has no value, then the "does not contain" doesn't match such fields. That seems wrong to me. It is that oddity that led me to overgeneralize in my initial post. But "has no value" does work properly for regular fields.

However, it is looking like a bug to me that "has no value" for custom fields doesn't match.


I reported this problem some time ago to member services, as I started seeing this behavior in a 2.7.x release. I gave them step-by-step instructions to duplicate and the same opinion about this being non-intuitive behavior. When I indicated I had used a workaround, they basically punted on the issue. It really ought to be fixed.

User avatar
mkmurray
Senior Member
Posts: 3241
Joined: Tue Jan 23, 2007 9:56 pm
Location: Utah
Contact:

Postby mkmurray » Sun Nov 09, 2008 6:04 pm

Apparently this bug should be posted on the MLS Feature Requests and Bug Reports wiki page.

tw.lbean
New Member
Posts: 17
Joined: Sat Nov 08, 2008 10:20 pm
Location: Vista, CA, USA

Postby tw.lbean » Sun Nov 09, 2008 6:06 pm

mkmurray wrote:Apparently this bug should be posted on the MLS Feature Requests and Bug Reports wiki page.


I have seen no way to do that. I would love for it to be posted there. I poked around there a while.

A nice new feature would be to have built-in support in MLS for DNC members. No geocodes, no custom fields, etc... :)

User avatar
mkmurray
Senior Member
Posts: 3241
Joined: Tue Jan 23, 2007 9:56 pm
Location: Utah
Contact:

Postby mkmurray » Sun Nov 09, 2008 6:10 pm

tw.lbean wrote:I have seen no way to do that. I would love for it to be posted there. I poked around there a while.

A nice new feature would be to have built-in support in MLS for DNC members. No geocodes, no custom fields, etc... :)

So it sounds like you might have already found this thread:

http://tech.lds.org/forum/showthread.php?t=2268

To post in the wiki, you need to obtain an LDSAccount; see this link:

http://ldsaccount.lds.org/

tw.lbean
New Member
Posts: 17
Joined: Sat Nov 08, 2008 10:20 pm
Location: Vista, CA, USA

Postby tw.lbean » Sun Nov 09, 2008 6:59 pm

mkmurray wrote:So it sounds like you might have already found this thread:

http://tech.lds.org/forum/showthread.php?t=2268

To post in the wiki, you need to obtain an LDSAccount; see this link:

http://ldsaccount.lds.org/


I went to the latter and created an account. I still can't login to the wiki site.

Is there a lag between creating account and having it working for the wiki?

User avatar
mkmurray
Senior Member
Posts: 3241
Joined: Tue Jan 23, 2007 9:56 pm
Location: Utah
Contact:

Postby mkmurray » Sun Nov 09, 2008 7:21 pm

tw.lbean wrote:I went to the latter and created an account. I still can't login to the wiki site.

Is there a lag between creating account and having it working for the wiki?

Yes, this is a known bug that the Church Employees are working on fixing. There is a lag time of a few hours to a day before your account gets granted access to the wiki login system.

jfackerson
Member
Posts: 68
Joined: Mon May 12, 2008 8:34 am
Location: Longview, Washington, USA

DNC vs BishopOnly & Bishop Contact Only

Postby jfackerson » Sun Nov 09, 2008 8:42 pm

Aside from the fact that by labeling our Brothers and Sisters as Do Not Contact (DNC) we, the Clerks, are essentially passing judgement on them and assigning them to execommunicated or disfellowshiped status without a Bishop's Court, I much prefer the label, Bishop Contact Only, or BishopOnly added to data field, Primary Phone Number.

We've created data field, Response to HT / VT, and add such comments as
"Requested no personal visits, but will receive monthly letter from quorum".

Adding such a field, output can include a column for this field.
We can't use it directly to exclude results unless we added
such a data field to every individual member or to
every head of house within our ward.
Then we could set up our query statement to include,
Response to HT / VT is empty or contains no data, etc.

Just a sermon, not a thought.


Return to “MLS Support, Help, and Feedback”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest