Help needed with strange anomaly in MLS

Discussions around using and interfacing with the Church MLS program.
jasondavie
New Member
Posts: 38
Joined: Sat Oct 05, 2013 6:44 pm
Location: Brisbane, Australia

Help needed with strange anomaly in MLS

Postby jasondavie » Sat Oct 05, 2013 7:14 pm

Hi everyone,

Hopefully you can help me....

We have a particular household record (let's call it the 'Smith' record for this purpose) that presents problems in MLS on our ward computer.

The family shows up correctly on LDS.org and LDS Tools, but when viewed in MLS, the family is displayed incorrectly NO MATTER HOW MANY times I have tried to change it.

MLS only shows the non-member father and 2 of the children. The mother is a member.
There are actually 4 children in the household - 3 with the same last name and 1 with a different last name.

I have tried deleting the non-member father's record. This allows the mother to be shown as head of house, but it still only shows 2 of the children. When trying to add the other 2 children, it says that it was done, but they NEVER appear as household members. In fact, if I try to add the child with a different last name, the name of the entire household always is changed to the last name of the child from 'Smith' like it should be.

When you view the 2 children as individuals, if you click to see what household they are attached to, the correct household is displayed, but again, if you actually look at the 'Smith' household, the 2 children are not displayed.

The problem seems to be highlighted by an accompanying issue. When you 'scroll' through household records using the right arrow, you can scroll all the way through the members' records from A until you get to the 'Smith' record. Upon arriving at the Smith household, you can no longer continue to scroll using the right arrow to go past this particular household. In order to get past it you have to use the 'magnifying glass' icon between the left and right arrows and manually select the next family which comes after Smith in alphabetical order. You can then continue to scroll all the way to Z after doing that.

This problems seems to suggest that there is a definite problem with this particular household's record.

No matter how many attempts to change it or how many send/receives are performed, it never corrects itself. I even phoned support in the US and they sent through a 'backup' of the ward's records. This still had no effect on the problem.

Please help!!!

Jason.

russellhltn
Community Administrator
Posts: 20726
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Help needed with strange anomaly in MLS

Postby russellhltn » Sat Oct 05, 2013 7:25 pm

jasondavie wrote:The problem seems to be highlighted by an accompanying issue. When you 'scroll' through household records using the right arrow, you can scroll all the way through the members' records from A until you get to the 'Smith' record. Upon arriving at the Smith household, you can no longer continue to scroll using the right arrow to go past this particular household. In order to get past it you have to use the 'magnifying glass' icon between the left and right arrows and manually select the next family which comes after Smith in alphabetical order. You can then continue to scroll all the way to Z after doing that.


I'd suggest a MLS backup and immediate restore. That rebuilds the indexes in the database. Failing that, you need to go back to clerk support. Most of us in the forum are just users, so we can't dig into your system and fix data corruption problems.

Also, what are you seeing in each of the views? Note that just because the name is on the parent's record doesn't mean the record is in the ward.
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

jasondavie
New Member
Posts: 38
Joined: Sat Oct 05, 2013 6:44 pm
Location: Brisbane, Australia

Re: Help needed with strange anomaly in MLS

Postby jasondavie » Sat Oct 05, 2013 7:31 pm

Thanks.

All of the children's records are in the ward. Hence being able to see all of them correctly on lds.org and lds tools app.

I'll try the backup and restore option.

I hope I don't have to call clerk support in the US again, because I could barely communicate what the problem was and the message I sent was just answered with a 'call us' reply. It's also quite painful with the connection from Australia to the US. There was a horrible delay which made it very difficult to talk to each other.

Some other members suggested this forum. I'm glad I found it because I didn't know it even existed.

eblood66
Senior Member
Posts: 2023
Joined: Mon Sep 24, 2007 8:17 am
Location: Cumming, GA, USA

Re: Help needed with strange anomaly in MLS

Postby eblood66 » Sat Oct 05, 2013 7:59 pm

jasondavie wrote:Thanks.

All of the children's records are in the ward. Hence being able to see all of them correctly on lds.org and lds tools app.

I'll try the backup and restore option.

I hope I don't have to call clerk support in the US again, because I could barely communicate what the problem was and the message I sent was just answered with a 'call us' reply. It's also quite painful with the connection from Australia to the US. There was a horrible delay which made it very difficult to talk to each other.

Some other members suggested this forum. I'm glad I found it because I didn't know it even existed.

You may want to download the full MLS installer from the RKATS site and reinstall just in case the problem is with your MLS install rather than the data. Probably it won't help but there is a possibility.

jasondavie
New Member
Posts: 38
Joined: Sat Oct 05, 2013 6:44 pm
Location: Brisbane, Australia

Re: Help needed with strange anomaly in MLS

Postby jasondavie » Sat Oct 05, 2013 8:08 pm

RKATS hey? I'm learning new stuff with every post! If I do a clean reinstall, will I still be able to reload my backed up data without compromising it?

russellhltn
Community Administrator
Posts: 20726
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Help needed with strange anomaly in MLS

Postby russellhltn » Sat Oct 05, 2013 8:25 pm

jasondavie wrote:RKATS hey? I'm learning new stuff with every post! If I do a clean reinstall, will I still be able to reload my backed up data without compromising it?


I'd do a "on top of" install first. When you do "patch" installs, I think the Java engine can fall behind. The complete install insures that Java is "current" to what MLS expects. (This is a hidden version, not to be confused with what you see in Add/Remove Programs).

Note that in doing a restore, your finances will be locked until you do a few send/receives to assure it that it is up to date.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

Gary_Miller
Senior Member
Posts: 1216
Joined: Thu Dec 08, 2011 10:42 am
Location: Emmett, Idaho

Re: Help needed with strange anomaly in MLS

Postby Gary_Miller » Sat Oct 05, 2013 8:57 pm

When you say LDS.Org are you saying it looks correct in the directory or in clerk resources.

If it looks good in clerk resources I think I would do a data refresh before I restored the backup to see what happens. That just might clear up the problem.

jasondavie
New Member
Posts: 38
Joined: Sat Oct 05, 2013 6:44 pm
Location: Brisbane, Australia

Re: Help needed with strange anomaly in MLS

Postby jasondavie » Sun Oct 06, 2013 2:19 am

The household and individual records of all the household members are displayed correctly on both the directory and the clerk resources section of LDS.org.

It's only on the unit's computer/MLS that there is a problem.

I'm not sure what you mean by a 'data refresh'. Do you mean do a send/receive? I don't know what the difference is between a data refresh and using the restore from backup function.

jasondavie
New Member
Posts: 38
Joined: Sat Oct 05, 2013 6:44 pm
Location: Brisbane, Australia

Re: Help needed with strange anomaly in MLS

Postby jasondavie » Sun Oct 06, 2013 4:17 am

Oh, do you mean select File - request data refresh? That makes sense.
Last edited by jasondavie on Sun Oct 06, 2013 5:01 am, edited 1 time in total.

User avatar
Biggles
Senior Member
Posts: 914
Joined: Tue May 27, 2008 4:14 am
Location: Watford, England

Re: Help needed with strange anomaly in MLS

Postby Biggles » Sun Oct 06, 2013 4:30 am

jasondavie wrote:The household and individual records of all the household members are displayed correctly on both the directory and the clerk resources section of LDS.org.

It's only on the unit's computer/MLS that there is a problem.

I'm not sure what you mean by a 'data refresh'. Do you mean do a send/receive? I don't know what the difference is between a data refresh and using the restore from backup function.


I think what is being suggested is to do a 'Request Unit Data Refresh'. In MLS this is found under the File menu at the top left of the screen. Click on that option, then do a send/receive. Then do another send/receive, after waiting for a short time.

Depending on when you do this, it can take several hours, or as little as 15 minutes, before the fresh data download is available


Return to “MLS Support, Help, and Feedback”

Who is online

Users browsing this forum: No registered users and 1 guest