Spontaneous reboot on send/receive

Discussions around using and interfacing with the Church MLS program.
russellhltn
Community Administrator
Posts: 20757
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Spontaneous reboot on send/receive

Postby russellhltn » Mon Jan 21, 2013 1:32 am

Got a ward whose computer (WinXP SP3) does a spontaneous reboot when you try to send/receive. I've already tried installing MLS overtop. I haven't exhausted my bag of tricks, but I wanted to see if anyone else has seen this.
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

jdlessley
Community Moderators
Posts: 6526
Joined: Sun Mar 16, 2008 11:30 pm
Location: USA, TX

Re: Spontaneous reboot on send/receive

Postby jdlessley » Mon Jan 21, 2013 2:50 am

It is possible the auto-reboot is caused by an unseen BSOD. Have you disabled the automatic restart feature for system failures so you can read and record the error message? The procedure is found here. With the Stop message you can identify the cause. I generally just do a Google search on the message to find out what is causing the trouble.
JD Lessley
Have you tried finding your answer on the LDS.org Help Center page or the LDSTech wiki?

russellhltn
Community Administrator
Posts: 20757
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Spontaneous reboot on send/receive

Postby russellhltn » Wed Jan 23, 2013 11:44 am

I'm not 100% sure what fixed it, but after running disk error checking (Chkdsk), and doing a send/receive via the Internet (instead of dial-up modem) it's working now. It was probably the ChkDsk. I'm sure I ran it before, but didn't check all the time-consuming options. This time I did.

Note that Backup/Restore did not fix the problem.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

russellhltn
Community Administrator
Posts: 20757
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Spontaneous reboot on send/receive

Postby russellhltn » Thu Jan 24, 2013 2:28 am

Well, that was a bust. I took the machine back to the ward and on initial checkout it crashed again. It is a BSOD. DRIVER_IRQL_NOT_LESS_OR_EQUAL, stopping at D1. Sometimes with no dll mentioned, sometimes afd.sys. This seems to point to a network problem, but I'm not sure what. I've updated modem drivers with no luck. I notice Sophos is at 10.0 while the stake machine is 10.2. Comments seem to indicate that "third party firewalls" could be the culprit.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

User avatar
johnshaw
Senior Member
Posts: 1834
Joined: Fri Jan 19, 2007 1:55 pm
Location: Syracuse, UT

Re: Spontaneous reboot on send/receive

Postby johnshaw » Thu Jan 24, 2013 6:23 am

This is the reason I really like having an image for a computer... a quick re-image rather than spending time troubleshooting is a time-saver for me... of course, if it's a hardware problem that won't fix it, but will help eliminate a software problem.
“A long habit of not thinking a thing wrong, gives it a superficial appearance of being right, and raises at first a formidable outcry in defense of custom.”
― Thomas Paine, Common Sense

russellhltn
Community Administrator
Posts: 20757
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Spontaneous reboot on send/receive

Postby russellhltn » Sat Feb 02, 2013 4:27 am

This continues to get stranger. I reloaded the C partition (this was a machine that I installed Desktop 5.5 when I rolled it out, so I could roll back the C drive). I may have made the mistake of updating everything - because it still crashes.

I moved the hard drive to the stake machine. Same model. Still crashes. So I think I can eliminate hardware problems - except maybe the hard drive or unless the stake machine has the same hardware fault. The hard drive has passed each test I give it. I could try the factory WD test. As well as switching the stake machine to dial up just to see if it does the same thing.

But it seems the evidence is pointing to software. Yet I uninstalled TEM and Sophos. Still it will frequently fail when the modem connects.

What a pain.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

russellhltn
Community Administrator
Posts: 20757
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Spontaneous reboot on send/receive

Postby russellhltn » Sat Feb 02, 2013 7:33 pm

Interesting. After thinking about this overnight, I decided to see if I could make the Stake machine do dial-up. (Not the stake machine with the ward's hard drive - but the stake machine all by itself.) It's been on broadband for several months. Nope. No BSOD, but it locks up on each attempt.

At this point I think there's some kind of conflict between MLS dial-up and a fully patched machine. The reason this isn't a big issue (yet) is that dial-up only machines are not likely to be fully patched. And I may be the first one to fight this battle.

There are a couple of things I can try. Both machines were built from the old Desktop 5.5 disks which had some “interesting” settings. Maybe if a built one from scrach, it might work.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

jdlessley
Community Moderators
Posts: 6526
Joined: Sun Mar 16, 2008 11:30 pm
Location: USA, TX

Re: Spontaneous reboot on send/receive

Postby jdlessley » Sat Feb 02, 2013 9:23 pm

Since the problem is related to dial-up operations have you checked to see if Digital Line Detect is installed? Uninstalling it was a checklist item for fresh installs of Windows XP for clerk computers to avoid any connection issues. If Digital Line Detect is installed it could be interfering with modem operations. -- Just a thought.
JD Lessley
Have you tried finding your answer on the LDS.org Help Center page or the LDSTech wiki?

russellhltn
Community Administrator
Posts: 20757
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Spontaneous reboot on send/receive

Postby russellhltn » Sat Feb 02, 2013 10:33 pm

Digital Line Detect does not appear to be installed.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

russellhltn
Community Administrator
Posts: 20757
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Spontaneous reboot on send/receive

Postby russellhltn » Mon Feb 04, 2013 1:59 am

Update: My new build dies after installing Sophos. Seems to be some kind of incompatibility with dial-up. It's doing the same things as the Stake machine did - locks up. However, that's at a point before it used to crash. So I must have been dealing with a least a variant of the problem - if not a different problem altogether.

Since my uninstaller is a BAT file, I'll try and remove just the firewall to see if I can retain anti-virus.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.


Return to “MLS Support, Help, and Feedback”

Who is online

Users browsing this forum: No registered users and 1 guest