MLS restore from backup issue

Discussions around using and interfacing with the Church MLS program.
mcg30916
New Member
Posts: 9
Joined: Sun Jan 06, 2013 10:23 pm

MLS restore from backup issue

Postby mcg30916 » Sun Jan 06, 2013 10:31 pm

I have MLS installed on a laptop with the intent to use it for leadership training on a projector for ward conferences. I had a ward bring a backup of their MLS on a flash drive. However the restore fails as my installation was done with our stake unit number and tells me the unit number is not the same. I tried uninstalling MLS including deleting the folder and subfolders it creates and then reinstalling. But the unit info is cached somewhere. Does anyone know how to clear this so that when I install and open it starts with no info and asks for the unit number?

russellhltn
Community Administrator
Posts: 20762
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: MLS restore from backup issue

Postby russellhltn » Sun Jan 06, 2013 11:20 pm

I think you would be better off having them bring the ward computer. Policy prohibits life MLS data from being loaded on personally-owned machine. There are a number of things that are locked after a restore that won't be cleared until a send/receive is done. (And that will create even more problems.)
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

jdlessley
Community Moderators
Posts: 6526
Joined: Sun Mar 16, 2008 11:30 pm
Location: USA, TX

Re: MLS restore from backup issue

Postby jdlessley » Mon Jan 07, 2013 12:53 am

mcg30916 wrote:I have MLS installed on a laptop with the intent to use it for leadership training on a projector for ward conferences. I had a ward bring a backup of their MLS on a flash drive.

The Policy and Guidelines for Computers Used by Clerks for Church Record Keeping, 18 Aug 2009, policy letter does not permit the installation of MLS with live data on personal computers. The only authorized installation of MLS on a personal computer is for training purposes using test data.

I am sure no one would intentionally disregard Church policy and therefore only use Church owned computers to install MLS with live data. With that Church policy noted I think we can continue.

mcg30916 wrote:[T]he restore fails as my installation was done with our stake unit number and tells me the unit number is not the same.
The unit must be added to that MLS installation before a restore can be accomplished. That is why the unit number was not recognized. To add a unit to an MLS installation see Adding additional units to MLS.

While the following information in this post is not necessary in solving the original problem I believe it may be useful to others.

mcg30916 wrote:I tried uninstalling MLS including deleting the folder and subfolders it creates and then reinstalling. But the unit info is cached somewhere.
You will note that during an uninstall there is a message that states the folders and files created after the install will not be deleted. Some of the folders and files created after install are the unit data folders and files. I am guessing you did not remove the unit data folders like you thought. The unit data folders are located in "C:\Documents and Settings\All Users\LDS Church\MLS\data\units" for Windows XP and "C:\ProgramData\LDS Church\MLS\data\units" for Windows 7 (note: "C:\ProgramData\LDS Church\MLS" is a hidden folder).

Procedurally there is no need to uninstall MLS to add another unit to the installation. Just add the unit and then restore the backup. But when restoring backups for a unit already added to the MLS installation I have found that deleting that unit data folder, adding the unit in again, and then restoring from a backup is the simplest method of restoring a backup without locking the finance section of MLS.
JD Lessley
Have you tried finding your answer on the LDS.org Help Center page or the LDSTech wiki?


Return to “MLS Support, Help, and Feedback”

Who is online

Users browsing this forum: No registered users and 1 guest