Reports slow

Discussions around using and interfacing with the Church MLS program.
craiggsmith
Senior Member
Posts: 711
Joined: Sun Sep 12, 2010 2:14 pm
Location: South Jordan, Utah

Reports slow

Postby craiggsmith » Tue Nov 20, 2012 8:30 pm

A clerk is reporting that reports are taking a very long time to run as of the past week or two. Anyone else experiencing this?
Craig
STS
South Jordan, UT

User avatar
aebrown
Community Administrator
Posts: 14693
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Postby aebrown » Tue Nov 20, 2012 9:53 pm

craiggsmith wrote:A clerk is reporting that reports are taking a very long time to run as of the past week or two. Anyone else experiencing this?


What does "reports" mean? Most reports in MLS are available in a matter of seconds. Are we talking financial or membership? Any particular reports? Is it the time to generate (display) the report, or printing?
Questions that can benefit the larger community should be asked in a public forum, not a private message.

craiggsmith
Senior Member
Posts: 711
Joined: Sun Sep 12, 2010 2:14 pm
Location: South Jordan, Utah

Postby craiggsmith » Tue Nov 20, 2012 10:33 pm

They specifically mentioned a custom report, I think membership. And the time to generate/display. Yes, it usually just takes a second or two, now it's taking around 10 minutes. I was thinking the database might be corrupted, but not sure.
Craig
STS
South Jordan, UT

russellhltn
Community Administrator
Posts: 20763
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Tue Nov 20, 2012 10:53 pm

You may want to use the MLS backup and then restore. That forces MLS to rebuild its indexes.

But first I'd check the windows logs for any sign of disk failure. A bad drive can really slow a system down as it struggles to recover the data.

Assuming the drive is healthy, a defrag would not be a bad idea.
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

craiggsmith
Senior Member
Posts: 711
Joined: Sun Sep 12, 2010 2:14 pm
Location: South Jordan, Utah

Postby craiggsmith » Wed Nov 21, 2012 7:03 am

Thanks, yes, I was thinking of doing a backup and restore but I'll check the logs. This is a fairly new machine but I'll check the fragmentation as well. Thanks again.
Craig
STS
South Jordan, UT


Return to “MLS Support, Help, and Feedback”

Who is online

Users browsing this forum: No registered users and 1 guest