MLS Graphing Program Update

Discussions around using and interfacing with the Church MLS program.
R-Enemy-p40
New Member
Posts: 15
Joined: Mon Feb 11, 2008 1:50 pm
Contact:

MLS Graphing Program Update

Postby R-Enemy-p40 » Tue Feb 26, 2008 11:00 pm

I just released a new version. You can get it here.

Thanks for those testing this out. Hopefully you'll find the additions useful. I did make a major change by making it work for .NET 2.0, however, I don't have a computer I can test this out on. Can someone who hasn't upgraded to 3.0/3.5 please download it and test it for me.

R-Enemy

Still one big thing on my to do list is to include pie charts. So, this will be coming soon.

R-Enemy-p40
New Member
Posts: 15
Joined: Mon Feb 11, 2008 1:50 pm
Contact:

Postby R-Enemy-p40 » Wed Feb 27, 2008 7:55 am

Figured I'd better list the changes on this post too, in case you don't want to click the link above to read the changes:

http://www.whitelawdesigns.com/

version 1.03 (2/26/2008)

Big update: Added single ward support. When importing a single ward file the ward name comes over as "Totals". It also imports the % data too. You can now re-name and change the color on any of the wards and data lines by right-clicking the item. Added single graph mode. This allows you to quickly compare wards. Added data labels on the graph. Added fixed 0 y-axis option to better compare data. Added equal y-axis to better compare data. Added customizable background colors. Added smooth line feature. Added symbol changes for data lines. Now uses line number on imports rather than data name. This will compensate for the name change that happened a few quarters ago. Just import a new quarter first if you want the new name. Otherwise, import and then re-name. Now runs on .NET 2.0 Framework instead of .NET 3.5 Framework.

User avatar
aebrown
Community Administrator
Posts: 14685
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Postby aebrown » Wed Feb 27, 2008 9:00 am

R-Enemy wrote:I just released a new version. You can get it here.

Thanks for those testing this out. Hopefully you'll find the additions useful. I did make a major change by making it work for .NET 2.0, however, I don't have a computer I can test this out on. Can someone who hasn't upgraded to 3.0/3.5 please download it and test it for me.


Actually, the previous version worked fine on .NET 2.0, which surprised me since you had mentioned that it required .NET 3.5. I ran it on a machine that only had .NET 2.0 installed -- I was curious what the error message would be. Contrary to my expectations, it ran just fine. I'll check out the new version to make sure that's still the case.

You also might want to take a look at the 25 Feb 2008 Presiding Bishopric letter detailing changes in the quarterly report. It looks like some line numbers have changed on the quarterly report starting in April, so you may need to make some adjustments to your data import routines.

R-Enemy-p40
New Member
Posts: 15
Joined: Mon Feb 11, 2008 1:50 pm
Contact:

Postby R-Enemy-p40 » Wed Feb 27, 2008 12:30 pm

Thanks for the heads up on the line numbers. I'll look into this. Also, the error I thought that might happen when using .NET 2.0 would've been when checking for updates. If that works fine then I guess we're good. That is interesting though because in Visual Studio it was first set to a target of 3.5 so I assumed it wouldn't work on 2.0. When I changed it to 2.0 I did have to update a few things, but mainly the web stuff to check for updates.

Thanks,
Randy

unixguy
New Member
Posts: 41
Joined: Sun Mar 04, 2007 7:43 pm

Postby unixguy » Wed Feb 27, 2008 8:27 pm

Alan_Brown wrote:You also might want to take a look at the 25 Feb 2008 Presiding Bishopric letter detailing changes in the quarterly report. It looks like some line numbers have changed on the quarterly report starting in April, so you may need to make some adjustments to your data import routines.


Is this letter available online, or can someone give us a brief description of the changes?

User avatar
marianomarini
Senior Member
Posts: 594
Joined: Sat Jan 19, 2008 3:13 am
Location: Vicenza. Italy
Contact:

Problems with login

Postby marianomarini » Thu Feb 28, 2008 2:30 am

When program starts it show me an ID "Vicenza 1 2" and ask for a password.
Because there are 2 units that share the Pc how can the program distinguish between the two?
Of course any try to login failed!

R-Enemy-p40
New Member
Posts: 15
Joined: Mon Feb 11, 2008 1:50 pm
Contact:

Postby R-Enemy-p40 » Sat Mar 01, 2008 9:29 am

Sorry, I have no idea what you're asking. Is it MLS or your network asking for a login? My graphing program doesn't need any login so if you're trying to run it from a network drive and you're being asked for a username and password, it must be for the network login.

User avatar
marianomarini
Senior Member
Posts: 594
Joined: Sat Jan 19, 2008 3:13 am
Location: Vicenza. Italy
Contact:

Postby marianomarini » Sat Mar 01, 2008 11:44 am

Sorry, you are right. The problem occur with another program that use MLS database.
I posted int the wrong forum, I'll try your graphic program very soon.
Sorry again.Image

frigby-p40
New Member
Posts: 1
Joined: Mon Mar 31, 2008 7:37 pm

Postby frigby-p40 » Mon Mar 31, 2008 7:58 pm

Do you have a link to download your MLS graph program?

User avatar
opee
Member
Posts: 332
Joined: Mon Jun 25, 2007 2:00 am
Location: Grand Rapids, MI

Postby opee » Mon Mar 31, 2008 9:36 pm

Download page (from a few posts earlier...)


Return to “MLS Support, Help, and Feedback”

Who is online

Users browsing this forum: No registered users and 1 guest