Inconsistency with e-mail address being visible/invisible

Share discussions around the Classic Local Unit Website (LUWS).
dmaynes
Member
Posts: 233
Joined: Sat Nov 01, 2008 9:50 am
Location: Pleasant Grove, Utah

Inconsistency with e-mail address being visible/invisible

Postby dmaynes » Wed Jan 07, 2009 9:11 pm

Has anyone else seen this behavior on the LUWS?

There is an envelope icon next to the member's name in the normal mode (blue screens) when you look at the ward directory. But, the e-mail address is displayed in "gray" font next to the member's name in the administrator mode (green screens).

I noticed this when I was scrubbing the e-mail list to make sure that a public list distributed to one of the ward leaders did not disclose an e-mail that the member requested to remain private.

Thanks,
Dennis

russellhltn
Community Administrator
Posts: 20734
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Wed Jan 07, 2009 9:57 pm

I checked just now and saw the same thing.

But I don't see it as a problem.
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

dmaynes
Member
Posts: 233
Joined: Sat Nov 01, 2008 9:50 am
Location: Pleasant Grove, Utah

Postby dmaynes » Thu Jan 08, 2009 7:33 pm

RussellHltn wrote:I checked just now and saw the same thing.

But I don't see it as a problem.


As I see it, there are two possibilities:
1) The member doesn't want the e-mail address to be displayed, but it is displayed.
2) The member wants the e-mail address to be displayed, and it shows up in a "grey" font on the website administrator screens.

Because this member's husband has suppressed the display of his e-mail address, and because I know how he feels about spam and other e-mail issues, I believe that #1 is the reality. If this is so, this is a big problem.

I can contact the member and ask the question, but then I might create anxiety if the e-mail address is being displayed and the member doesn't want it displayed. The only way to know for sure is to ask the member.

If #2 is reality, I agree with you. It's not a problem.

Thanks,
Dennis

User avatar
aebrown
Community Administrator
Posts: 14685
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Visibility of e-mail addresses in LUWS

Postby aebrown » Thu Jan 08, 2009 8:03 pm

I think there is some confusion in this thread regarding the designed and normal behavior of LUWS in regard to e-mail addresses. Just so everyone is clear on this:

  1. A user enters their e-mail address as they register, and can update in in their User Profile.
  2. In Update Profile, a user is presented with the question "Show your e-mail address in directories and lists?" to which they may answer Yes or No.
If the user answers Yes, then

  1. In the normal pages (Blue), an envelope icon will be displayed by their name in membership directories (and leadership directories, if they are leaders). Clicking on that icon will produce a popup for sending e-mail to the person; their e-mail address is clearly displayed in that popup.
  2. In the administrator pages (Green), their e-mail address will be displayed in black text by their name in Membership directories.
If the user answers No, then

  1. In the normal pages (Blue), no icon will be displayed by their name in membership or leadership directories. As far as any normal user can tell, the person has no e-mail address in the system.
  2. In the administrator pages (Green), their e-mail address will be displayed in gray text by their name in Membership directories. This indicates that although the administrator can see the e-mail, normal users will not be able to see it.
So now with the intended functionality clear, I will respond in another post to the specific question posed in this thread.

User avatar
aebrown
Community Administrator
Posts: 14685
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Postby aebrown » Thu Jan 08, 2009 8:16 pm

dmaynes wrote:There is an envelope icon next to the member's name in the normal mode (blue screens) when you look at the ward directory. But, the e-mail address is displayed in "gray" font next to the member's name in the administrator mode (green screens).


I have never seen this behavior. What you describe is the behavior in normal mode (envelope icon) for a person who has not hidden his e-mail address, but the behavior in admin mode (gray e-mail address) for a person who has hidden his e-mail address.

This inconsistency makes no sense, and if it is happening as you describe, is most definitely a bug.

dmaynes wrote:As I see it, there are two possibilities:
1) The member doesn't want the e-mail address to be displayed, but it is displayed.
2) The member wants the e-mail address to be displayed, and it shows up in a "grey" font on the website administrator screens.

Because this member's husband has suppressed the display of his e-mail address, and because I know how he feels about spam and other e-mail issues, I believe that #1 is the reality. If this is so, this is a big problem.

I can contact the member and ask the question, but then I might create anxiety if the e-mail address is being displayed and the member doesn't want it displayed. The only way to know for sure is to ask the member.

If #2 is reality, I agree with you. It's not a problem.


I don't see how you can avoid contacting the member. If the user has requested that the e-mail address be suppressed, but it is showing up, then you have a responsibility to do whatever is necessary to make sure the e-mail address is not exposed. This may be awkward, but is necessary.

If they have set their User Profile to not show the e-mail address, one thing you might try is asking them to update their profile to show the e-mail address, click Submit, then immediately go back into their profile, set it to not show the e-mail address, and click Submit. Then check to see if by chance this has reset the setting so it is handled consistently. This reset method may also help in the opposite case.

In any case, you should report this problem using the Feedback link (which will go to your stake admin, who can then use his Feedback link to send the problem to LUWS Support). Although option #2 is less of a problem, I would disagree with those who say it is not a problem. That would still mean that the admin mode is showing an e-mail address in gray for someone who has specified in their profile that they want their e-mail address displayed. That is misleading to the administrator and should be fixed. Otherwise the gray/black text of an e-mail address would mean nothing because it would be unreliable.

russellhltn
Community Administrator
Posts: 20734
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Thu Jan 08, 2009 9:08 pm

RussellHltn wrote:I checked just now and saw the same thing.


I take that back. I was looking at two different members of the same household.

So the one that shows in gray in the admin screen doesn't show a email in the regular member screen.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

dmaynes
Member
Posts: 233
Joined: Sat Nov 01, 2008 9:50 am
Location: Pleasant Grove, Utah

Postby dmaynes » Sun Jan 11, 2009 8:39 am

Alan_Brown wrote:This inconsistency makes no sense, and if it is happening as you describe, is most definitely a bug.

I don't see how you can avoid contacting the member. If the user has requested that the e-mail address be suppressed, but it is showing up, then you have a responsibility to do whatever is necessary to make sure the e-mail address is not exposed. This may be awkward, but is necessary.


I have contacted the member. It is definitely this member's desire that the e-mail address not be displayed and that an e-mail icon not be shown next to the name. They have had trouble with a lot of spam and infections. They have barely restored their machine to usable status, so I don't have an update on their efforts in resetting the icon, yet.

Thanks,
Dennis

gregneg
New Member
Posts: 49
Joined: Fri Feb 01, 2008 7:15 am
Location: Elk Grove, California, USA (At the moment)

Postby gregneg » Sat Jan 17, 2009 12:43 pm

Email address is in MLS (a second source, other than website registration). If you need to dump the envelope icon, then your Membership Clerk needs to delete it from the MLS membership record.

zaneclark
Senior Member
Posts: 907
Joined: Thu Jan 24, 2008 4:34 pm
Location: Las Vegas, NV
Contact:

Postby zaneclark » Sat Jan 17, 2009 1:51 pm

elderj1 wrote:Email address is in MLS (a second source, other than website registration). If you need to dump the envelope icon, then your Membership Clerk needs to delete it from the MLS membership record.

I thought that the envelope icon only showed when the person was registered for the site. I am going to do a little experiment this week by temporarily adding an email address on the MLS to a member that is not registered and see if it shows on the site membership list. I have often thought the email address on the MLS was largely wasted since it didn't show anyplace, so it would be a good thing if it did appear on the site listing.

User avatar
aebrown
Community Administrator
Posts: 14685
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Postby aebrown » Sat Jan 17, 2009 2:13 pm

elderj1 wrote:Email address is in MLS (a second source, other than website registration). If you need to dump the envelope icon, then your Membership Clerk needs to delete it from the MLS membership record.


This statement is incorrect. The e-mail address in MLS has absolutely no effect on the LUWS. The e-mail address in LUWS comes only from the user's profile on LUWS.

Thus deleting the e-mail address in MLS will not cause the envelope icon in LUWS to disappear.


Return to “Classic Ward & Stake Sites (LUWS)”

Who is online

Users browsing this forum: No registered users and 1 guest