Indexing program: Could not find web browser

Issues related to FamilySearch Indexing
Bütyök
New Member
Posts: 1
Joined: Mon Mar 03, 2014 1:41 pm

Indexing program: Could not find web browser

Postby Bütyök » Mon Mar 03, 2014 2:16 pm

I am using Ubuntu 12.04 and Chromium 32.0.1700.107 web browser and I have installed the indexing program two days ago. I always get a message when I click to a link or the 'Rewiew batches' button: "Error attempting to launch web browser: Could not find web browser." Any ideas?

mark_h_dewey
New Member
Posts: 20
Joined: Sun Apr 01, 2012 12:58 pm

Re: Indexing program: Could not find web browser

Postby mark_h_dewey » Sun Jul 13, 2014 12:37 am

I use Xubuntu 14.04 and am an avid indexer. However, I've found that when I click links in the indexing software that it opens the wrong web browser, instead of my default web browser. The web browser it opened (Epiphany) had issues, too, like when I would close it, it would freeze the indexing software because Epiphany didn't close properly (so the only way to fix that was to kill the indexing software (with xkill or some such) or else open a task manager and kill Epiphany (which is somehow still running). Plus, the web browser must be in the same thread (the kind of thread you use in programming) or something, because the indexing software freezes while Epiphany is open.

Anyway, I uninstalled Epiphany in an attempt to get it to default to another web browser (because I really didn't like the freezing), but then I get the same error you (Bütyök) get when I click links. Reinstalling Epiphany may or may not remove the error, but it's certainly not a solution. Why isn't my default browser launching?

Anyway, this is a problem, because I can't really index (in good conscience) without being able to open a web browser and see the examples, instructions and such. If I could copy/paste the links it wouldn't matter which browser was to launch on clicking them, but that's not an option.

So, apparently, it seems Xubuntu has multiple kinds of default web browser systems. Which one is the indexing software using? How do I configure it?

Anyway, my web browser of choice is Maxthon, currently, due to how it's so much faster than everything else (the current Linux version, anyway).

mark_h_dewey
New Member
Posts: 20
Joined: Sun Apr 01, 2012 12:58 pm

Re: Indexing program: Could not find web browser

Postby mark_h_dewey » Sun Jul 13, 2014 1:34 am

I found an answer to all our questions. It is a miracle. Use the Windows emulator (Wine) to install the Windows version of the indexing software. This will allow it to work on 64-bit systems, and my default web browser works with it, this way (plus, it doesn't freeze the indexing software). Anyway, it seems to work just fine through Wine on my Linux system, but I haven't tested it very far, yet. If you've tried it through Wine on previous Ubuntu versions, it's a lot different, now.

Because user-agent switchers may not allow you to download the Windows version of the software, here's the URL to download it (I used a Windows emulated web browser to get the URL):

https://indexing.familysearch.org/downl ... indows.exe


Return to “FamilySearch Indexing”

Who is online

Users browsing this forum: No registered users and 1 guest