Search function does not work in Gospel Library

Discussions around the Gospel Library application for Windows for Desktop and Mobile
Bendegeit
New Member
Posts: 1
Joined: Sat Dec 27, 2014 1:03 pm

Search function does not work in Gospel Library

Postby Bendegeit » Sat Dec 27, 2014 1:10 pm

I have the same problem using the app on my Windows 8.1 device.
I downloaded the Gospel Library on to this computer this morning and can't 'find' anything in any of the documents I've downloaded (including all the General Conference issues back to '71.

This service has always worked on my Galaxy S3 phone (though not well--seems to be missing a lot and I find I have to work hard to find a passage I know exists).

For what it's worth, when I open SETTINGS I can find no setting for 'enable indexing' nor an option to more 'Advanced Settings.'

Ironically, I just downloaded the app onto my daughter's Kindle and I noticed that shortly after it loaded, a bit of energy and data was absorbed first downloading and then merging indexes for all the docs I pulled down.

Makes me wonder if there's a way to force download and merging of indexes since this is clearly what I'm missing.

jdlessley
Community Moderators
Posts: 6526
Joined: Sun Mar 16, 2008 11:30 pm
Location: USA, TX

Re: Search function does not work in Gospel Library

Postby jdlessley » Sat Dec 27, 2014 4:58 pm

[Moderator note: This thread was split from the Search function does not work in Gospel Library thread in the Android Gospel Library forum because the applications are for different operating systems. Development of each app is a separate effort and need to be addressed separately.]
JD Lessley
Have you tried finding your answer on the LDS.org Help Center page or the LDSTech wiki?

ToManyLetters
Member
Posts: 387
Joined: Sun Mar 31, 2013 12:16 pm

Re: Search function does not work in Gospel Library

Postby ToManyLetters » Sat Dec 27, 2014 9:19 pm

Bendegeit,

There are a few possibilities for why the search results aren't showing up as you're expecting. Let's work through each of these to see if we can find a resolution:

1. Your index is still being built. This may sound silly, but if you've downloaded a huge chunk of content, the index itself may still be building in the background while the application is running. Let the app just sit at the home screen for a few minutes and try searching again. If that doesn't work, try #2:

2. The search is working, but not how you expect it to. There are two varieties of searches in Gospel Library for Windows. A quick, go to search and a full search. Both of these searches can be accessed using the search button in the navigation bar.

By simply typing into the search box, you search the titles and chapter names of all content you have downloaded. Go To Search is especially good for finding the names of lessons or the numbers of hymns.

If Go To Search doesn't find what you're looking for, pressing "enter" or clicking or tapping on the little magnifying glass beside the search box will search inside all downloaded content for your search terms (a "full" search). Because there will likely be quite a few of these, the results are sorted into categories for easy perusal.

3. There's actually a bug here, and we need to track it down. This is our first public release for Windows, and there's every possibility of an actual search bug. The first troubleshooting step here would be to uninstall and reinstall the application and redownload the content you need. Give it a few minutes, then run a simple search--for something like "Jesus" or "Faith" and see what turns up.

No matter your result, let us know what happens so we can figure out how to move forward.
Have a bug to report for Gospel Library for Windows v4? Check the Known Issues to see if it's been reported. (https://tech.lds.org/wiki/Gospel_Library_for_Windows_Preview_Issues)
Also visit the FAQ. (tech.lds.org/wiki/Gospel_Library_for_Windows_8_FAQ)


Return to “Gospel Library for Windows”

Who is online

Users browsing this forum: No registered users and 1 guest