Video bugs, Japanese references bug

Discussions around the Gospel Library application for Windows for Desktop and Mobile
koman
New Member
Posts: 3
Joined: Sat Sep 13, 2014 10:08 pm

Video bugs, Japanese references bug

Postby koman » Sat Sep 13, 2014 10:47 pm

Hi,
First, thanks for the great work! I'm really liking the beta, and am excited to see all these great features as they continue to get incorporated!

That said, I've discovered a few bugs -- all I saw in the app was a link to this site (or to email), so I'm assuming I should post bug-reports here? I'm running the beta app, version 2.0.0.43 (as far as I know, this is the most recent version??)

1)
I've noticed that if I try to make videos full-screen, they kind of become full-screen, but don't cover the top title-bar (including the < and > arrows and location information right under it), and they don't cover up the charms on the left (like Home, library, bookmark, etc) (I tried this with the "Religious Freedom" video). Or, with the Johnny Lingo, the video comes in too big to even fit on the screen (there is a scroll bar), but with full-screen, the video seems to adjust to the height, minus the title-bar constraint.

I'm running Windows 8.1, displayed on an external monitor with 1920 x 1080 resolution (if this helps at all).

2)
If I navigate to another part of the app (say, I click on "home"), while a video is running, it continues to run in the background, and I can continue to hear the audio. If I try clicking "back" to get back to the video page to stop it, it just shows a new video player, ready to start the video again (I can actually get multiple rounds of the same video playing in this manner).

3)
The Japanese language Book of Mormon lists references ("footnotes") as a circled number -- kind of like (1), (2), etc. However, if you click on any of them, it brings up the "References" bar and has the footnotes as 4a, 4b, etc, instead of 4(1), or 4(2) ... (more of a minor bug than anything)

Once again, great app overall! I'll continue to let you know if I discover anything else!

Kenji

spencerto
New Member
Posts: 25
Joined: Thu Feb 07, 2013 11:08 am

Re: Video bugs, Japanese references bug

Postby spencerto » Sun Sep 14, 2014 5:13 am

Hi Kenji,

The Video's right now are "in-line" within the content and really behave just as an in-line video would in a web browser. We don't have much control of it at this time. We have plans to put major work into the "media" portion of the application in future builds where we will take over more control of the media and solve the 2 problems you have correctly identified.

I'll look into the references issue with the Japanese Book of Mormon to see if I can determine the cause of this inconsistency. It may be an issue with the content and I'll verify if we have similar behavior on Android and iOS.

UPDATE: Ok, I looked into the Japanese Reference issue and confirmed that this is an inconsistency with the content and is replicated on at least Android and probably on iOS as well, but I'll have to confirm that later. The content is provided to the platforms as a SQLite file with several tables in it. The primary table is called "node" and contains the actual chapter content. Within this content, the <sup></sup> tags are used to denote the footnote and in this case it is the circled numbers like circle(1), etc. However another table called "ref" contains the actual cross reference values. In that table, the names are listed as 1a, 1b, etc. Thus the inconsistency. In order for this to render properly and match, the content provider should either change the markup to match using letters or change the "ref" table names to be circle numbers. I don't know if the content teams plan to change this in the future.

Thanks for your report.
Tony

koman
New Member
Posts: 3
Joined: Sat Sep 13, 2014 10:08 pm

Re: Video bugs, Japanese references bug

Postby koman » Wed Sep 17, 2014 8:35 am

Tony,
Thanks for your update/ information! As I said, I really appreciate all that you guys do for us!

As for the content teams, I'm not sure where I would go to contact them (sorry, I haven't had the time to search around at the moment), but perhaps you could pass the following on to them?

If they wanted to stay consistent with the Japanese printed text, they would want to keep the circle format ( (1), (2), etc), as that is what appears in the hard copies of the Book of Mormon.

Also, someone pointed this out at Institute, but apparently the formatting for "Lord" has been removed in the Bible in the electronic version. The printed text has 2 renditions of "Lord" -- one as written, with the first letter capitalized, and another "LORD", where the remaining letters are all in caps too (but a smaller caps). Apparently the 1st rendition is for "master", or similar type of words, while "LORD" was explicitly for "Jehovah". So, rendering both forms of the word the same loses this information.

If you can't pass this info on, let me know, and I'll try to find out how to contact them, but in any case, thanks again!

Kenji

User avatar
sbradshaw
Senior Member
Posts: 2494
Joined: Mon Sep 26, 2011 8:42 pm
Location: Provo, UT
Contact:

Re: Video bugs, Japanese references bug

Postby sbradshaw » Tue Sep 30, 2014 9:52 pm

spencerto wrote:... the Japanese Reference issue ... probably on iOS as well ...

Verified as a content issue on iOS as well.
Samuel Bradshaw • Interested in church apps and sites, creative recordkeeping, clerk support, YSA wards and stakes, LDS music, Vineyard at BYU, and online service.

alexandergblack
New Member
Posts: 10
Joined: Thu Oct 23, 2014 9:00 am

Re: Video bugs, Japanese references bug

Postby alexandergblack » Thu Oct 23, 2014 9:09 am

The video bug of them not going completely fullscreen has been fixed, I believe. The playback issue where it keeps playing after returning to a different page has also been fixed. This is in the Beta V 2.0.0.54 version.

ToManyLetters
Member
Posts: 387
Joined: Sun Mar 31, 2013 12:16 pm

Re: Video bugs, Japanese references bug

Postby ToManyLetters » Thu Oct 23, 2014 1:01 pm

Both video issues were indeed fixed with Public Beta 2.3.1 (app version 2.0.0.54).
Have a bug to report for Gospel Library for Windows v4? Check the Known Issues to see if it's been reported. (https://tech.lds.org/wiki/Gospel_Library_for_Windows_Preview_Issues)
Also visit the FAQ. (tech.lds.org/wiki/Gospel_Library_for_Windows_8_FAQ)


Return to “Gospel Library for Windows”

Who is online

Users browsing this forum: No registered users and 1 guest