Newsletter Admin Privileges timeout?

Discussions about the Newsletter Tool at LDS.org.
shem.simmons
New Member
Posts: 28
Joined: Wed Feb 11, 2015 10:14 am

Newsletter Admin Privileges timeout?

Postby shem.simmons » Sun Feb 22, 2015 1:39 pm

I'm having an issue with my newsletter privileges "timing out". When I first log in to lds.org I have access to admin settings and I can publish new articles, but after a few minutes I suddenly lose my privileges and can only view the newsletter as an average member would. Logging off and logging back on does not resolve the problem, neither does restarting the browser, but if I log in using a different browser then my privileges return, but only for a few more minutes... After I lose them on the second browser, they don't return on the first, but I can log on again using a third browser, and then I have them back again for a few more minutes.

My privileges do eventually return to all browsers over time, but I've not been able to determine exactly how long I have to wait until they "reset". I've determined today that they will return after about 1-2 hours.

Is any one else running into this issue? It's really annoying when you're trying to teach the auxiliaries how to use the newsletter when the system keeps logging me out, and it's really discouraging to try and post a new article only to have it erased because you took too long to type it out.

mevans
Senior Member
Posts: 1280
Joined: Tue May 22, 2012 12:52 pm
Location: California, USA

Re: Newsletter Admin Privileges timeout?

Postby mevans » Tue Feb 24, 2015 8:42 am

Does this mean that the "Admin" link completely disappears on the page after refreshing it, or is it still there for you, but clicking on the link doesn't work?

I haven't experienced this myself, but I'm not doing Admin functions very often. I've been logged in to lds.org for a while and just checked and I can still administer the Newsletter.

Since changing browsers gives you temporary access, you could try clearing your browser cache/cookies/etc.. Does that restore access temporarily for you without having to change browsers?

What calling (or callings) do you have that give you access to the Newsletter administration? Or are you added as an explicit administrator (not through a calling)?

shem.simmons
New Member
Posts: 28
Joined: Wed Feb 11, 2015 10:14 am

Re: Newsletter Admin Privileges timeout?

Postby shem.simmons » Tue Feb 24, 2015 10:37 am

The "Admin" link, and the "New Article" and the edit buttons all disappear consistently after about ten minutes of first viewing the newsletter. The frustrating thing is if I'm working on a post, and it takes me a while to write and format, then when I click to save I'm directed to a screen that says, "Page does not exist or you do not have access." It's literally like my privileges are timing out after a certain amount of time in each browser.

I just tested it, and clearing the cache, cookies, history and everything else for the past hours seems to do the trick to restore my access (I'm required to log back in again after), but ten minutes later and it's gone again.

I'm wondering if all our issues with the website have anything to do with our location? I'm in Canada, does being from a different country change the way things are handled on the server at all? What else could be causing this?

russellhltn
Community Administrator
Posts: 20732
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Newsletter Admin Privileges timeout?

Postby russellhltn » Tue Feb 24, 2015 10:43 am

shem.simmons wrote:The "Admin" link, and the "New Article" and the edit buttons all disappear consistently after about ten minutes of first viewing the newsletter. The frustrating thing is if I'm working on a post, and it takes me a while to write and format, then when I click to save I'm directed to a screen that says, "Page does not exist or you do not have access." It's literally like my privileges are timing out after a certain amount of time in each browser.

But after this you don't have to log back in? If you take too long in formatting the newsletter, your login may time out. It wouldn't be the case of your admin privileges timing out but the entire login timing out.
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

shem.simmons
New Member
Posts: 28
Joined: Wed Feb 11, 2015 10:14 am

Re: Newsletter Admin Privileges timeout?

Postby shem.simmons » Tue Feb 24, 2015 12:35 pm

My login does not time out, just the admin privileges, and it appears to be after a ten minute interval.

It's only after I clear my cache that I have to log back in.

mevans
Senior Member
Posts: 1280
Joined: Tue May 22, 2012 12:52 pm
Location: California, USA

Re: Newsletter Admin Privileges timeout?

Postby mevans » Wed Feb 25, 2015 6:54 am

Hi shem.simmons. Thanks for the info so far; I didn't see an answer to this:
What calling (or callings) do you have that give you access to the Newsletter administration? Or are you added as an explicit administrator (not through a calling)? Also: do you have any out-of-unit callings?

I don't know if it's a clue or not, but maybe it will help us figure out something.

I doubt being in Canada affects things.

The fact that it goes away after 10 minutes makes me wonder if it has anything to do with cookies, as they can have a time limit. I have no idea how Newsletter is implemented; I'm just making a guess at things based on the behavior you're seeing.

Have you tried disabling any browser add-ins/extensions to see if that makes the problem go away?

mevans
Senior Member
Posts: 1280
Joined: Tue May 22, 2012 12:52 pm
Location: California, USA

Re: Newsletter Admin Privileges timeout?

Postby mevans » Wed Feb 25, 2015 7:11 am

shem.simmons: I don't know if looking at things like browser settings and cookies is something your comfortable with or something that scares you. I cleared all my browsing data and logged in again to see what gets created by logging in and going to the Newsletter.

I found two "interesting" cookies that seem to have something to do with the newsletter (member-news). Could you take a look at these two cookies to see if there's an expiration that might correspond with the 10 minutes you're experiencing?

site: lds.org; cookie: s_ppv
I found this cookie with some data that referred to member-news. Mine is set to expire when the browsing session ends.

site: http://www.lds.org; cookie: member-news-persist
This cookie is far more interesting, as mine has an expiration time, which is 5 hours after it was created. Does this cookie have an expiration time for you? If so, does it correspond with the 10 minutes you're experiencing?

I might very well be leading you on a pointless chase with this. I just tried deleting those cookies while logged in to see if the Newsletter Admin features would go away and they did not.

russellhltn
Community Administrator
Posts: 20732
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Newsletter Admin Privileges timeout?

Postby russellhltn » Wed Feb 25, 2015 10:06 am

Just as a thought, can you check and make sure the date, time and time zone on your computer is correct.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

shem.simmons
New Member
Posts: 28
Joined: Wed Feb 11, 2015 10:14 am

Re: Newsletter Admin Privileges timeout?

Postby shem.simmons » Wed Feb 25, 2015 12:10 pm

I'm the Ward Website Administrator, I don't have any out-of-unit callings, I do have two other callings within the unit: Building Representative and Assistant Venturer Advisor, but only my Website Administrator calling gives me admin access to the newsletter.

I've been testing in multiple browsers (Chrome, firefox, IE, Safari, Opera), some do not have any add-ons or extensions at all.

site: lds.org; cookie: s_ppv Is set to expire at end of session for me also

site: lds.org; cookie: member-news-persist is also a 5 hour cookie for me.

I've been testing on multiple computers as well (2 Macs, 1 PC), on several different networks (Home, work, and Church). My date, time, and time zone are correct on all computers.

I can't duplicate the behaviour, if I delete every cookie except ObSSOCookie–which I've determined is the single sign on cookie–the site will still function normally. After the "time-out" if I delete all of the non-session cookies, then my privileges are restored. I'm still trying to determine if there is one cookie that is the problem cookie...

shem.simmons
New Member
Posts: 28
Joined: Wed Feb 11, 2015 10:14 am

Re: Newsletter Admin Privileges timeout?

Postby shem.simmons » Wed Feb 25, 2015 1:28 pm

I've confirmed that the cookie giving me trouble is member-news-persist.

My browsers can't seem to agree when this cookie is set to expire, some are saying after 5 hrs, some are saying after 24hrs. They're all liars because this cookie is certainly expiring after exactly 10 minutes (for me anyways). After ten minutes, I can manually delete the cookie, refresh the page, and admin privileges are immediately restored (sometimes I have to delete the cookie and refresh more than once, but it eventually works).

Is anyone else able to confirm that this cookie is actually expiring in 10 minutes? Any ideas as to why this would be happening to me?


Return to “Newsletter”

Who is online

Users browsing this forum: No registered users and 1 guest