Showing up as Spanish Site

Discussions about the Newsletter Tool at LDS.org.
gwhitehead
New Member
Posts: 1
Joined: Wed Oct 01, 2014 7:33 am

Showing up as Spanish Site

Postby gwhitehead » Wed Oct 01, 2014 7:36 am

I'm the Bishop of our ward and we are trying to really use the newsletter. Grove Creek 4th Ward, Grove Creek Stake. The other day a weird thing happened. When I login at home it is either portuguese or spanish, I¹m not sure. But, yesterday when I logged in at work it was back to English. This morning at home it is back to spanish.

I attached the image. I logged in as me, then navigated to the newsletter and that's what I see.
Attachments
Boletín.png
Image of the error
(596.52 KiB) Downloaded 223 times

jdlessley
Community Moderators
Posts: 6522
Joined: Sun Mar 16, 2008 11:30 pm
Location: USA, TX

Re: Showing up as Spanish Site

Postby jdlessley » Wed Oct 01, 2014 9:31 am

This is a problem that has been cropping up from time to time over the past two years or more. You can recover the language to English by changing the language designator at the end of the URL from "lang=spa" to "lang=eng". Then clear your browser cache so that the cached pages will be replaced with the English version.

I have not seen a permanent fix for this issue since it was first reported. Some have suggested it may be a Church server issue.
JD Lessley
Have you tried finding your answer on the LDS.org Help Center page or the LDSTech wiki?

russellhltn
Community Administrator
Posts: 20734
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Showing up as Spanish Site

Postby russellhltn » Wed Oct 01, 2014 10:29 am

jdlessley wrote:This is a problem that has been cropping up from time to time over the past two years or more.

It's a lds.org problem, not just a newsletter problem. It strikes at random, usually affects just a specific area for a specific person but can hit any area.
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

User avatar
sbradshaw
Senior Member
Posts: 2484
Joined: Mon Sep 26, 2011 8:42 pm
Location: Provo, UT
Contact:

Re: Showing up as Spanish Site

Postby sbradshaw » Sat Oct 11, 2014 8:21 pm

Aside: I like the idea your ward has of posting missionary letters on the newsletter!
Samuel Bradshaw • Interested in church apps and sites, creative recordkeeping, clerk support, YSA wards and stakes, LDS music, Vineyard at BYU, and online service.

User avatar
barkeraj
Church Employee
Church Employee
Posts: 130
Joined: Thu Nov 09, 2006 9:15 am
Location: Springville, UT

Re: Showing up as Spanish Site

Postby barkeraj » Mon Jan 05, 2015 2:37 pm

We have someone looking into this problem. As mentioned before this used to be an lds.org wide issue. We thought we had fixed it across the site, but apparently it is still happening here on newsletter.

Unfortunately, it is a very tricky bug to reproduce. It doesn't happen for everyone and for those it does happen to it is usually sporadic.

How you can help:
If this happens to you, does it happen every time, or just sometimes?
Can you track the times it does happen back to certain browsers or computers (if you use multiple of either)?
If you only ever use one browser/computer, can you try using another browser and see if it persists?
Have you tried clearing your cookies/cache?
Do you currently have this problem on other sections of lds.org? I specifically say currently, since we think we have it fixed elsewhere. So if it happened to you back in July, that doesn't help. It needs to be a current reproduction of other sections having the issue.
If you have a lang=spa in your URL does changing it to lang=eng fix it in the current session. If you come back later does it continue to fix it or does it revert back to Spanish?

Will add other questions as I (or my QA guy) think of them.

mevans
Senior Member
Posts: 1280
Joined: Tue May 22, 2012 12:52 pm
Location: California, USA

Re: Showing up as Spanish Site

Postby mevans » Mon Jan 05, 2015 11:03 pm

I've seen the language problem occur with the Newsletter. It's not happening right now, but here's what I know:
  • Lately I've only accessed the Newsletter on a Mac, so I don't know if it's a problem on Windows or mobile devices. I'm using either FF or Chrome.
  • Usually I'm navigating to the Newsletter from the Directory by using the Tools menu. The Directory is in English, the Newsletter is in Spanish, and when I select "Lesson Schedules (in Spanish) from the Tools menu, then Lesson Schedules appears in English, so the web site isn't staying in Spanish when I go elsewhere; it's just the Newsletter.
  • If I change "=spa" to "=eng" and reload the page, the Newsletter reverts to English.
  • The problem is intermittent.
  • I don't believe I've tried clearing the cache/cookies and I don't remember when I've accessed it from another computer if I've seen the problem there or not. I'll try to pay attention when I see it again and report back.

What did you find when fixing the overall LDS.org Spanish (and sometimes other languages) problem? Is there anything that might be relevant here we should be looking at?

User avatar
barkeraj
Church Employee
Church Employee
Posts: 130
Joined: Thu Nov 09, 2006 9:15 am
Location: Springville, UT

Re: Showing up as Spanish Site

Postby barkeraj » Tue Jan 06, 2015 8:36 am

mevans wrote:What did you find when fixing the overall LDS.org Spanish (and sometimes other languages) problem? Is there anything that might be relevant here we should be looking at?


If memory serves me correctly, it was a caching issue where the first language to hit the server after an update is what got cached on our CDN. Unfortunately that only partially applies here, as this whole section was architected differently to not do caching like the rest of the site does. So it is not apples to apples.

mevans
Senior Member
Posts: 1280
Joined: Tue May 22, 2012 12:52 pm
Location: California, USA

Re: Showing up as Spanish Site

Postby mevans » Wed Jan 07, 2015 7:51 am

So far the Newsletter has been coming up in English for me every time. I'll keep trying it regularly to see if I can get it in Spanish again.

mevans
Senior Member
Posts: 1280
Joined: Tue May 22, 2012 12:52 pm
Location: California, USA

Re: Showing up as Spanish Site

Postby mevans » Wed Jan 28, 2015 6:46 am

mevans wrote:So far the Newsletter has been coming up in English for me every time. I'll keep trying it regularly to see if I can get it in Spanish again.


I've been accessing the Newsletter pretty much every day since my previous post and it's always English now. Either you solved the problem or that bug is scared of me now that I'm paying attention to it.


Return to “Newsletter”

Who is online

Users browsing this forum: No registered users and 1 guest