Unable to attach PDF

Discussions about the Newsletter Tool at LDS.org.
leesat
New Member
Posts: 17
Joined: Sun Jul 15, 2012 9:09 pm

Unable to attach PDF

Postby leesat » Sat Aug 04, 2012 5:44 pm

I have been trying to attach a PDF to the newsletter tool without success. I have tried with Safari, Firefox, and another member has tried with IE. Each time it appears to attach, then says 'error' in red. While newsletter was in beta, I was able to attach PDF, but since going live, haven't been able to.

jdlessley
Community Moderators
Posts: 6526
Joined: Sun Mar 16, 2008 11:30 pm
Location: USA, TX

Postby jdlessley » Sat Aug 04, 2012 6:03 pm

I tried both the drag-and-drop method of attaching a file and the select-a-file method of attaching a file and had no problem in Firefox 14.0.1, IE8, and Chrome. If you do not select a category for the article, then clicking the Save button does nothing. There is no error message but the article is not saved. Perhaps there may be issues with the file you are trying to attach.
JD Lessley
Have you tried finding your answer on the LDS.org Help Center page or the LDSTech wiki?

User avatar
aebrown
Community Administrator
Posts: 14693
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Postby aebrown » Sat Aug 04, 2012 6:04 pm

leesat wrote:I have been trying to attach a PDF to the newsletter tool without success. I have tried with Safari, Firefox, and another member has tried with IE. Each time it appears to attach, then says 'error' in red. While newsletter was in beta, I was able to attach PDF, but since going live, haven't been able to.


How big is the PDF you are trying to attach? In my experimenting, I have found that most files less than about 1.6MB upload just fine, but files greater that 1.7MB give the error "Service Unavailable" every time.

I don't think I ever pushed these size limits during the beta, so I can't comment on whether this apparent size limitation is a new problem or an problem carried forward from the beta.

You might want to try smaller files to see if that makes a difference. I'm not saying that this is not a problem -- to my thinking, it's clearly a bug, since the limit should be higher, and even if you exceed the limit, the error message should be more descriptive -- but it will it least help you better understand how to work within the current limitations.
Questions that can benefit the larger community should be asked in a public forum, not a private message.

jdlessley
Community Moderators
Posts: 6526
Joined: Sun Mar 16, 2008 11:30 pm
Location: USA, TX

Postby jdlessley » Sat Aug 04, 2012 6:24 pm

I just tried to attach a large file. It was 24.4 MB. The error message was "ERROR File is too large". I then tried a file that was 1.71 MB and the error message was "ERROR Service Unavailable". I continued reducing the file size 100 KB until I had success with a file that was 497 KB. So it looks like the file size limit is around 500 KB. I don't know at what file size the error message changes from "ERROR File is too large" to "ERROR Service Unavailable". But both indicate a file size limit.
JD Lessley
Have you tried finding your answer on the LDS.org Help Center page or the LDSTech wiki?

User avatar
aebrown
Community Administrator
Posts: 14693
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Postby aebrown » Sat Aug 04, 2012 6:29 pm

jdlessley wrote:I just tried to attach a large file. It was 24.4 MB. The error message was "ERROR File is too large". I then tried a file that was 1.71 MB and the error message was "ERROR Service Unavailable". I continued reducing the file size 100 KB until I had success with a file that was 497 KB. So it looks like the file size limit is around 500 KB. I don't know at what file size the error message changes from "ERROR File is too large" to "ERROR Service Unavailable". But both indicate a file size limit.


I think if you keep playing with it you'll find that the limit is not that simple. I've successfully uploaded files as big as 1,621KB, but failed on smaller ones.
Questions that can benefit the larger community should be asked in a public forum, not a private message.

leesat
New Member
Posts: 17
Joined: Sun Jul 15, 2012 9:09 pm

Postby leesat » Sat Aug 04, 2012 7:52 pm

Thanks, I will try all these suggestions and see how I go. I'll reduce the size even further, and try saving under a different catagory. Will post again after trying this with the results. Thanks for your help.

russellhltn
Community Administrator
Posts: 20758
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Sat Aug 04, 2012 8:53 pm

According to the help file, up to 5MB should be ok. No clue if that's individual or collective.
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

leesat
New Member
Posts: 17
Joined: Sun Jul 15, 2012 9:09 pm

Postby leesat » Sat Aug 04, 2012 9:17 pm

Ok, so I reduced the file even further, to 288 kb, and it still says ERROR Service unavailable. I've tried both drop and drag, and search for a file methods. Then I thought I might try re-writing the complete article as there may have been some problem. I resized it to 600kb, started clicked create article tab and wrote my article, the tried to attach PDF, still no go, then started a again, same size, but this time attaching the PDF first, no problem at all, then I was able write the article and save it. So it seems to want to attach the PDF first, then go onto writing the article. I'll make a note of that each time I add an article to see if it's common, but at least for this time it seems to have worked....interesting.

russellhltn
Community Administrator
Posts: 20758
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Sat Aug 04, 2012 9:21 pm

leesat wrote:Ok, so I reduced the file even further, to 288 kb, and it still says ERROR Service unavailable. I've tried both drop and drag, and search for a file methods. Then I thought I might try re-writing the complete article as there may have been some problem. I resized it to 600kb, started clicked create article tab and wrote my article, the tried to attach PDF, still no go, then started a again, same size, but this time attaching the PDF first, no problem at all, then I was able write the article and save it. So it seems to want to attach the PDF first, then go onto writing the article. I'll make a note of that each time I add an article to see if it's common, but at least for this time it seems to have worked....interesting.


How long did it take you to write the article? Help warns that it times out after 30 minutes.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

leesat
New Member
Posts: 17
Joined: Sun Jul 15, 2012 9:09 pm

Postby leesat » Sat Aug 04, 2012 9:46 pm

Initially it was an edit to an existing article, when that didnt work I just copy and pasted that article into the new one. So only a short time.


Return to “Newsletter”

Who is online

Users browsing this forum: No registered users and 1 guest