Lesson URLs cannot have a '#' character

Discussions about the Lesson Schedules Tool at lds.org.
mevans
Senior Member
Posts: 1280
Joined: Tue May 22, 2012 12:52 pm
Location: California, USA

Lesson URLs cannot have a '#' character

Postby mevans » Sun Jan 05, 2014 1:47 pm

Since the church hasn't made the Primary Sharing Time manual available in Lesson Schedule format, I'm trying to enter it with links to the PDF, as I did last year; however, this year, I'm trying to put in the links to the actual PDF page. I had a few problems with this last year, so I didn't link to the specific page. I believe my problems are different this year.

For example, try to put this in as a URL link for a lesson:

Code: Select all

www.lds.org/bc/content/shared/content/english/pdf/language-materials/10940_eng.pdf?lang=eng#page=4


I am unable to save the lesson if there's a pound/hash character in the URL. If I remove the page directive, it works, which defeats the purpose.

In fact, I cannot paste a # character in a URL in this forum: if I do so, I get a message that this website is temporarily down. If I wrapped it in CODE as I did above, I was able to save the URL.

jdlessley
Community Moderators
Posts: 6522
Joined: Sun Mar 16, 2008 11:30 pm
Location: USA, TX

Re: Lesson URLs cannot have a '#' character

Postby jdlessley » Sun Jan 05, 2014 5:10 pm

As a workaround, have you tried using a URL shortening service such as TinyURL?
JD Lessley
Have you tried finding your answer on the LDS.org Help Center page or the LDSTech wiki?

mevans
Senior Member
Posts: 1280
Joined: Tue May 22, 2012 12:52 pm
Location: California, USA

Re: Lesson URLs cannot have a '#' character

Postby mevans » Sun Jan 05, 2014 11:23 pm

jdlessley wrote:As a workaround, have you tried using a URL shortening service such as TinyURL?

That's my next plan when I have time again; I expect that it would work. My simple project of some pre-chuch updates almost made me late for church as I tried to figure out the # problem.

mstauff
Church Employee
Church Employee
Posts: 71
Joined: Thu Dec 02, 2010 9:25 am
Location: Lehi, UT USA

Re: Lesson URLs cannot have a '#' character

Postby mstauff » Mon Jan 06, 2014 10:05 am

I was able to enter that URL and have it save correctly (I tried it both just manually typing the URL with a #, and also copied and pasted your text from above), can anyone else confirm or reproduce the URL # issue?

User avatar
aebrown
Community Administrator
Posts: 14685
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Re: Lesson URLs cannot have a '#' character

Postby aebrown » Mon Jan 06, 2014 12:15 pm

mstauff wrote:I was able to enter that URL and have it save correctly (I tried it both just manually typing the URL with a #, and also copied and pasted your text from above), can anyone else confirm or reproduce the URL # issue?

I was able to save a TFOT lesson with the URL containing # with no problem. And clicking on the resulting link also worked fine, going to the correct page within the PDF. I'm using Firefox on Win7, if that matters.

mevans wrote:In fact, I cannot paste a # character in a URL in this forum: if I do so, I get a message that this website is temporarily down. If I wrapped it in CODE as I did above, I was able to save the URL.

I can also paste that URL in a Forum post, such as you see here.

mevans
Senior Member
Posts: 1280
Joined: Tue May 22, 2012 12:52 pm
Location: California, USA

Re: Lesson URLs cannot have a '#' character

Postby mevans » Mon Jan 06, 2014 2:42 pm

I just tried this in FF, Chrome, IE 11, and Opera on Windows 8.1 and I am unable to save any URL with a # in it. Yesterday I was on a Mac, but I don't remember which OS version or browser I was using.

I can save a lesson with a URL without a #, but as soon as the # character show ups, either on a new lesson, or updating an existing one, it won't save. Pressing the Save button does nothing.

russellhltn
Community Administrator
Posts: 20729
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Lesson URLs cannot have a '#' character

Postby russellhltn » Mon Jan 06, 2014 3:00 pm

Interesting. I see two things to look at to see why the different experience. First, all the ones who have been successful are all admins. Mevans, what level of rights do you have?

Second, could it be some interaction with the type of class/manual/type of lesson?
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

User avatar
aebrown
Community Administrator
Posts: 14685
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Re: Lesson URLs cannot have a '#' character

Postby aebrown » Mon Jan 06, 2014 3:29 pm

Personally, I think the most curious thing about this topic is mevans' report that he can't post URLs containing a # on the Forum, either. What possible connection could there be between the Lesson Schedules application and this phpBB-based LDSTech Forum?

russellhltn
Community Administrator
Posts: 20729
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Lesson URLs cannot have a '#' character

Postby russellhltn » Mon Jan 06, 2014 4:30 pm

Well! I can do it from my "Community Administrator" account, but I sure can't do it from my "sock puppet" account.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

larq
New Member
Posts: 15
Joined: Thu Jun 26, 2008 2:27 pm
Location: USA

Re: Lesson URLs cannot have a '#' character

Postby larq » Mon Jan 06, 2014 4:38 pm

russellhltn wrote:Well! I can do it from my "Community Administrator" account, but I sure can't do it from my "sock puppet" account.

But I can: see here. Curiouser and curiouser....


Return to “Lesson Schedules”

Who is online

Users browsing this forum: No registered users and 1 guest