Clicking on lesson title and then returning and editing causes eternal spinner

Beta Lesson Schedules Website feedback
eblood66
Senior Member
Posts: 2028
Joined: Mon Sep 24, 2007 8:17 am
Location: Cumming, GA, USA

Clicking on lesson title and then returning and editing causes eternal spinner

Postby eblood66 » Sun Feb 12, 2012 11:36 pm

In the administration view, if I click on the title of a lesson (to go to the lesson elsewhere on lds.org) and then return to the view and edit, I get an eternal spinner.

To reproduce:

  1. Go to the Administration view
  2. Select the Year View for a class
  3. Click on a lesson link for a Class Manual lesson
  4. Hit the back button
  5. Click on the edit button for any lesson
  6. The spinner shows up and the page never loads
  7. If I reload the page it forces me to sign in to my LDS Account again
This is on Firefox 10.0.1 under Windows 7. Using Firebug it shows that when I click on the edit button it does a GET to https://www.lds.org/lesson/services/<myunitnumber>/lessons/8235 which returns a 302 error. Immediately after that it shows a GET to https://www.lds.org/SSOSignIn/.

jdcr256
Church Employee
Church Employee
Posts: 557
Joined: Wed Feb 17, 2010 1:53 pm
Location: Riverton, Utah

Postby jdcr256 » Mon Feb 13, 2012 11:05 am

Thanks for the report. The problem is that the chapter links are http. As soon as you visit a non-secure link, it kills your browser single-sign-on session for some reason. We'll probably end up switching all our manual/chapter links to use https.

ctbarrett
New Member
Posts: 20
Joined: Thu Dec 09, 2010 9:33 pm
Location: Edgewood, WA USA

Postby ctbarrett » Tue Feb 14, 2012 10:18 pm

Same problem here with Chrome.

eblood66 wrote:In the administration view, if I click on the title of a lesson (to go to the lesson elsewhere on lds.org) and then return to the view and edit, I get an eternal spinner.

To reproduce:

  1. Go to the Administration view
  2. Select the Year View for a class
  3. Click on a lesson link for a Class Manual lesson
  4. Hit the back button
  5. Click on the edit button for any lesson
  6. The spinner shows up and the page never loads
  7. If I reload the page it forces me to sign in to my LDS Account again
This is on Firefox 10.0.1 under Windows 7. Using Firebug it shows that when I click on the edit button it does a GET to https://www.lds.org/lesson/services/<myunitnumber>/lessons/8235 which returns a 302 error. Immediately after that it shows a GET to https://www.lds.org/SSOSignIn/.

jdcr256
Church Employee
Church Employee
Posts: 557
Joined: Wed Feb 17, 2010 1:53 pm
Location: Riverton, Utah

Postby jdcr256 » Wed Feb 15, 2012 10:22 am

Yep, this should happen in any browser, since the problem is in how LDS.Org handles authenticated sessions. It will be fixed when I next update the beta environment.


Return to “Beta Lesson Schedules”

Who is online

Users browsing this forum: No registered users and 1 guest