Editing a household unmaps that household

Discussions about the Maps Tool on lds.org.
jdlessley
Community Moderators
Posts: 6526
Joined: Sun Mar 16, 2008 11:30 pm
Location: USA, TX

Editing a household unmaps that household

Postby jdlessley » Wed Aug 22, 2012 2:00 pm

An unfortunate side affect of editing either emergency response text field, "Emergency Response" or "Special Needs", for a household is that the household location status changes to unmapped/"unknown location" and the location marker is removed from the map.

It appears that the edit option "Status" is defaulting to "unknown location", the first item on the list for status, when the "Categories" option is edited. The location status should not change unless user input is made.

If a category item is edited then the location status must also be edited to select the status that existed prior to editing to prevent the programming error from changing the location status to "unknown location".

Edit: Well, now the behavior has changed after several hours of testing to compose this post. I returned to LDS Maps to test another issue related to verifying a location and noted the behavior I reported above had changed (household status is not changing after editing emergency response categories). I hope it is because of program changes to Maps and not an issue on my end. The issue reported above had been occurring for over a week while I was verifying and editing emergency response data. I am leaving this post here as a reference should the issue repeat later.
JD Lessley
Have you tried finding your answer on the LDS.org Help Center page or the LDSTech wiki?

russellhltn
Community Administrator
Posts: 20767
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Wed Aug 22, 2012 2:05 pm

Is it always defaulting to "unknown" or does it make a attempt at a default location (as if the member just moved in)?
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

jdlessley
Community Moderators
Posts: 6526
Joined: Sun Mar 16, 2008 11:30 pm
Location: USA, TX

Postby jdlessley » Wed Aug 22, 2012 7:27 pm

RussellHltn wrote:Is it always defaulting to "unknown" or does it make a attempt at a default location (as if the member just moved in)?
For the issue I described, the actual location (the dot on the map) was not changed until the household detail pup-up was closed by clicking the Submit button. In all cases I had previously verified the household locations days earlier and was attempting to edit the emergency response categories.

The steps I had been using was -

  1. Open the household details pop-up.
  2. Click the Edit link.
  3. Click the Categories button.
  4. Edit one or both of the categories "Emergency Response" and "Special Needs".
  5. Save the changes by clicking the Submit button.
I had not been paying close attention to what was being displayed in the status when editing the categories until I noticed all the households in which I had edited the categories were missing on the map and displayed the unmapped icon in the directory list. That is when I started testing to find out what was happening.
JD Lessley
Have you tried finding your answer on the LDS.org Help Center page or the LDSTech wiki?

russellhltn
Community Administrator
Posts: 20767
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Wed Aug 22, 2012 9:30 pm

jdlessley wrote:I had not been paying close attention to what was being displayed in the status when editing the categories until I noticed all the households in which I had edited the categories were missing on the map and displayed the unmapped icon in the directory list. That is when I started testing to find out what was happening.


Can you tell if it was always unmapped, or just "reset"? In other words, were they addresses that the geocoder couldn't figure out?

Given the recent thread, I can see an update doing a reset. (It thought you updated the address.) But it would strike me as odd if it always made it unmapped.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

jdlessley
Community Moderators
Posts: 6526
Joined: Sun Mar 16, 2008 11:30 pm
Location: USA, TX

Postby jdlessley » Wed Aug 22, 2012 9:44 pm

RussellHltn wrote:Can you tell if it was always unmapped, or just "reset"? In other words, were they addresses that the geocoder couldn't figure out?
All the household locations had been previously verified either as "Exact Location" or "Approximate Location". Since I cannot replicate the issue now it may already be fixed or there may be another parameter or preceding set of conditions that caused the behavior that I am not aware of.
JD Lessley
Have you tried finding your answer on the LDS.org Help Center page or the LDSTech wiki?


Return to “Maps”

Who is online

Users browsing this forum: No registered users and 1 guest