Church Handbook Search Not Working?

Discussions about the Leader and Clerk Resources on lds.org.
sjpynes
New Member
Posts: 45
Joined: Thu Jan 03, 2008 1:30 pm
Location: San Diego, CA

Church Handbook Search Not Working?

Postby sjpynes » Mon Aug 13, 2012 4:13 pm

On the "Leader Resources" page, in the column down the right-hand side of the page is a little box titled "Church Handbook" that appears to allow searching in Handbook 1, Handbook 2, or both.

However, when I type a word in the text box and click the "Search" button it opens a new tab in the browser for search results, but there are never any results shown on the page (nor is there any error message).

Am I doing something wrong or is this just a bug?

JamesAnderson
Senior Member
Posts: 748
Joined: Tue Jan 23, 2007 2:03 pm

Postby JamesAnderson » Mon Aug 13, 2012 4:48 pm

Has to be a bug in Leader Resources. I can run a search on Handbook 2 on the Teaching and Learning page that has Handbook 2, and get multiple results. I ran the search here (note, after typing in your search, hit enter on your keyboard, the button below the search box is blank--has no text on the button, nor does it work).

http://www.lds.org/handbook/handbook-2-administering-the-church?lang=eng

I typed in 'baptism' (no quotes), and got 11 results.

User avatar
aebrown
Community Administrator
Posts: 14686
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Postby aebrown » Mon Aug 13, 2012 5:19 pm

JamesAnderson wrote:Has to be a bug in Leader Resources.


Indeed, that seems to be the case. When you search for "baptism" from Leader Resources, for example, the URL is:

Code: Select all

https://www.lds.org/search?collection%3Dserving-in-the-church%26publication%3DHandbook%202%3A%20Administering%20the%20Church%26query%3Dbaptism
but it should be

Code: Select all

https://www.lds.org/search?collection=serving-in-the-church&publication=Handbook%202%3A%20Administering%20the%20Church&query=baptism


It looks like the parameter string got improperly URL-encoded, so the & and = characters are encoded. When I decode those characters and resubmit the URL, the search results page shows the correct results.
Questions that can benefit the larger community should be asked in a public forum, not a private message.

sjpynes
New Member
Posts: 45
Joined: Thu Jan 03, 2008 1:30 pm
Location: San Diego, CA

Postby sjpynes » Thu Aug 16, 2012 4:18 pm

Is there some place to report a bug like this?

jdlessley
Community Moderators
Posts: 6522
Joined: Sun Mar 16, 2008 11:30 pm
Location: USA, TX

Postby jdlessley » Thu Aug 16, 2012 6:02 pm

The best avenue of report is by using the "Do You Have Feedback on This Page?" link on the bottom right of the page in a blue banner. With the recent update to LDS.org the old "Submit Feedback" link has been replaced by page specific links.
JD Lessley
Have you tried finding your answer on the LDS.org Help Center page or the LDSTech wiki?

sjpynes
New Member
Posts: 45
Joined: Thu Jan 03, 2008 1:30 pm
Location: San Diego, CA

Postby sjpynes » Fri Aug 17, 2012 5:10 pm

Interestingly enough, this page does not have a blue banner, but the search results page does, so I left the a message summarizing the info from this thread. Also, when you submit feed back, it shows the the referring link in box at the bottom of the page - sure enough it confirms aebrown's analysis of over-encoding.

Thanks.


Return to “Leader and Clerk Resources”

Who is online

Users browsing this forum: No registered users and 1 guest