"Data Not Available" Error Still Here!

Discussions about the Directory Tool on lds.org. Questions about the Directory on the classic site should be posted in the LUWS forum.
User avatar
AileneRHerrick
Member
Posts: 299
Joined: Mon Dec 08, 2008 2:33 pm
Location: Moses Lake, Washington, United States

"Data Not Available" Error Still Here!

Postby AileneRHerrick » Tue Jan 31, 2012 2:13 pm

I am the website administrator for my ward (I am not a clerk).

In the New Directory for our ward, the missionary section does not work, and has not worked for over a month. Whenever someone in our ward tries to click on it, it says, "Sorry, data is temporarily not available for this application. Please try again later." I thought it would resolve itself, but it has not. We are able to view missionary information for other wards within our stake, so it appears to be a problem isolated in our ward.

What I have tried:
  • Participating in a thread on the LDS Tech forums, I gave all the requested information to a user almost 4 weeks ago, and still no response.
  • Using the Feedback button the LDS.org website. They recommended that I have visit the forums (done), and have the clerk refresh the data. They gave me an email address to contact if that didn't work.
  • I had the ward clerk refresh the data, now over 72 hours ago, no luck.
  • Contacted the email address, and was again referred to the forums (done) and asked to use the Feedback button on LDS.org (done).


So I'm back again. I know you're all very happy to see me. ;)

What do I need to do? I feel like I've tried everything, but obviously I haven't because it's still not working. I know it can be fixed, but I'm not sure how! Will someone please lend a helping hand? Thank you!

lajackson
Community Moderators
Posts: 6128
Joined: Mon Mar 17, 2008 9:27 pm
Location: US

Postby lajackson » Tue Jan 31, 2012 3:35 pm

AileneRHerrick wrote:In the New Directory for our ward, the missionary section does not work, . . .

What I have tried:

  • LDS Tech forums
  • Feedback
  • ward clerk refresh
  • email



If you sent all of the information requested in post #5 of the other thread, I would suggest you send a PM to jdcr256 and ask him if he received the everything he needs to try and troubleshoot the issue. He may have it, but just be swamped with other priorities and not been able to get to this particular problem.

I would also suggest that you may wish to have your ward clerk try to access the data, and if he has the same problem, he might send his header data and information in as well to give the developers a second shot at finding the problem.

Your stake clerk may also be able to assist, or someone else outside your ward, to see if the problem is just happening for members of your ward or if other members in your stake also cannot access your ward missionary information.

After that, the hardest thing to do is to be patient until they can get the resources onto the problem and solve it.

User avatar
AileneRHerrick
Member
Posts: 299
Joined: Mon Dec 08, 2008 2:33 pm
Location: Moses Lake, Washington, United States

Postby AileneRHerrick » Tue Jan 31, 2012 4:25 pm

Thank you lajackson, that is a good idea. I will follow up with jdcr256.

I know for certain that it is happening for members of our ward. Would it have to be a clerk that sends the header information? I bet I could get my husband to do the same thing pretty quickly.

That's also a good idea to check to see if others outside of the ward are having a problem. I'll send an email to the stake web person.

Thanks for the suggestions!

lajackson
Community Moderators
Posts: 6128
Joined: Mon Mar 17, 2008 9:27 pm
Location: US

Postby lajackson » Tue Jan 31, 2012 4:33 pm

AileneRHerrick wrote: Would it have to be a clerk that sends the header information? I bet I could get my husband to do the same thing pretty quickly.


Post # 5 in the other thread was asking you to send your header information. If you have already sent it, I am not sure whether or not another header would help.

If you have not sent your header information, have your husband snag it for you and send it it. The header tells jdcr256 where to look to troubleshoot the problem.

User avatar
AileneRHerrick
Member
Posts: 299
Joined: Mon Dec 08, 2008 2:33 pm
Location: Moses Lake, Washington, United States

Postby AileneRHerrick » Tue Jan 31, 2012 4:35 pm

I sent him my header information at the beginning of January. When I followed up with jdcr256 just now, I asked him if he'd like another header as well. Thanks again for the suggestion!

jdcr256
Church Employee
Church Employee
Posts: 557
Joined: Wed Feb 17, 2010 1:53 pm
Location: Riverton, Utah

Postby jdcr256 » Wed Feb 01, 2012 4:57 pm

I did find a problem in the Directory code and fixed it. I'm fairly certain that it will resolve the issue you are having.

Basically, the missionary system was sending us data that there are two missionaries called from your ward, but neither of them are actively serving (one has not yet left for the MTC, the other is recently returned). The directory is designed to only show missionaries that are actively in the MTC or in the field, and the scenario of 2 called and 0 actively serving was not a scenario accounted for in the code.

I bring up the detail because sometimes the data we have in our development environment is not updated as quickly as the production data, so the issue I fixed may not be the same as the issue you are seeing. If what I described (with the two missionaries) is not actually the case in your ward, let me know and I can try to get access to the production data to see what else may be going on.

The problem in your ward will probably resolve itself before my fix makes it's way to our production environment. Our next release is a few weeks away, and the problem should go away when the status of those two missionaries changes (the newly called one entering the MTC, and the returning one getting cleaned out of the system.

User avatar
AileneRHerrick
Member
Posts: 299
Joined: Mon Dec 08, 2008 2:33 pm
Location: Moses Lake, Washington, United States

Postby AileneRHerrick » Wed Feb 01, 2012 5:05 pm

Thank you so much jdcr256!

We had a missionary return from the field in December (around the same time the problem started), so it sounds like you're probably correct in your determination. :)

There is currently one missionary in the field, I don't know when he is returning. I think he was in another ward when he was called, so he probably doesn't show up.

Then we have two missionaries leaving for the MTC this month.

Thank you so much for looking into this, I really appreciate it! :D


Return to “Directory”

Who is online

Users browsing this forum: No registered users and 1 guest