v2: Updating an event with cleanup time removes the cleanup time

Discussions about the Calendar Tool at lds.org. Questions about the calendar on the classic site should be posted in the LUWS forum.
User avatar
aebrown
Community Administrator
Posts: 14693
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

v2: Updating an event with cleanup time removes the cleanup time

Postby aebrown » Wed Oct 26, 2011 9:22 am

I created an event using the new setup/cleanup time features. That worked great. I had a one-hour event from 1:00 to 2:00, with 30 minutes setup before and 30 minutes cleanup after, so the location was reserved from 12:30 to 2:30. It displayed nicely in Week view with the 30 setup minutes before and the 30 cleanup minutes in gray. So far so good.

But then I edited that event and changed the 30 cleanup minutes to 60 minutes. When I saved my changes, I saw that the cleanup time had disappeared from the Week view. And indeed, when I clicked on the event, I saw that it was messed up. It said "Facility is available for setup starting at 12:30pm and for cleanup ending at 1pm." Note that ending cleanup time: it's not just that it's not at 3:00 as I asked, or 2:30 as it used to be, or even 2:00 when the event ends. It is displaying the event start time.

Nothing I can do to the event will enable me to restore any cleanup time. The only way I can get an event with cleanup time is to create it fresh (and never touch the cleanup time in any subsequent edits).
Questions that can benefit the larger community should be asked in a public forum, not a private message.

dshep2020
Member
Posts: 284
Joined: Mon Jan 22, 2007 11:43 pm

Postby dshep2020 » Wed Oct 26, 2011 9:29 am

I was just about to type up the same issue! I can confirm the same behavior. Even removing the setup/cleanup times, saving and re-adding doesn't fix it. As you stated, the cleanup time seems to be the issue.

russellhltn
Community Administrator
Posts: 20767
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Wed Oct 26, 2011 10:22 am

I saw that last night as well. Cleanup time always saves as zero. At least for prior events. I don't think I tried with a new one.
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

Aczlan
Member
Posts: 351
Joined: Sun Jun 06, 2010 4:29 pm
Location: Upstate, NY, USA

Postby Aczlan » Wed Oct 26, 2011 8:17 pm

I have also seen this (as reported in the beta forum).
I think that what is happening is that the cleanup time is being saved as a negative value or displayed in the popup as end time minus setup time (copy/paste of the code from the setup time?).
My event runs from 6PM to 9PM. I asked for a 30 minute setup window and a 45 minute cleanup window.
When I went to verify the event, the event popup said "Facility is available for setup starting at 5:30pm and for cleanup ending at 8:15pm"
If I changed the cleanup time to 30 mins, the "cleanup ending at" time changed to 8:30PM.
If I edited it in Chrome where the default cleanup time is blank and saved it as such, the "cleanup ending at" is 9PM.

Aaron Z

jdcr256
Church Employee
Church Employee
Posts: 557
Joined: Wed Feb 17, 2010 1:53 pm
Location: Riverton, Utah

Postby jdcr256 » Thu Oct 27, 2011 5:10 pm

This should be fixed now.


Return to “Calendar”

Who is online

Users browsing this forum: No registered users and 1 guest