v2.7: Error when generating PDF for printing

Discussions about the Calendar Tool at lds.org. Questions about the calendar on the classic site should be posted in the LUWS forum.
bromark
New Member
Posts: 1
Joined: Mon Nov 24, 2014 7:49 pm

v2.7: Error when generating PDF for printing

Postby bromark » Mon Nov 24, 2014 7:55 pm

[Moderator Note: This topic was split out from v2.7: Blank Printing, since it deals with a separate issue.]

fguthier wrote:
dahlfam wrote:The print calendar events is not working with this new release. I can print events in a month that are tied to a location but what I really need is to print all of the events from a calendar. Most of the events on this stake calendar are not tied to a location therefore do not print. This was working on the prior version and I am needing to print this ASAP for our stake directory

Also recognized that. Thats important to fix. Is there at least a workaround for now?
Regards
Flo

I also noticed print problem, the message says something about not being able to create the pdf. I tried to download the pdf anyway and there was nothing in the downloaded file.

russellhltn
Community Administrator
Posts: 20767
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: v2.7 bug: Blank agenda printing

Postby russellhltn » Tue Nov 25, 2014 1:07 am

I get "Error creating PDF" regardless of which type of calendar I select.
Have you searched the Wiki?
Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

russellhltn
Community Administrator
Posts: 20767
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: v2.7 bug: Blank printing

Postby russellhltn » Tue Nov 25, 2014 3:50 pm

Still not working for me. Regardless of type or date range. If I try to download a PDF, I get a file, but it's corrupted.
Attachments
Cal_PrintError.png
(48.28 KiB) Not downloaded yet
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

User avatar
aebrown
Community Administrator
Posts: 14693
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Re: v2.7 bug: Blank printing

Postby aebrown » Tue Nov 25, 2014 5:17 pm

russellhltn wrote:Still not working for me. Regardless of type or date range. If I try to download a PDF, I get a file, but it's corrupted.

This sounds like a different issue -- everyone else reporting here could successfully print (even before the fix), but the calendar was blank.

russellhltn
Community Administrator
Posts: 20767
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: v2.7 bug: Blank printing

Postby russellhltn » Tue Nov 25, 2014 6:10 pm

The problem appears to be the locations. If I add certain locations, I get the error. If I remove them, I get a preview. Out of 6 locations, only 2 do not give me any errors. Some locations that create the error have minimal or even no events. The error happens across multiple months, so I don't think it's event related.

I'm unable to see any pattern.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

walterfwildman
New Member
Posts: 8
Joined: Tue Dec 21, 2010 4:44 pm

Re: v2.7 bug: Blank printing

Postby walterfwildman » Tue Nov 25, 2014 9:44 pm

Jeff..
So you can put you efforts to the best use. I have check out the print problem. I appears to be only on Default Administrators. Users with View only access and added administrators can print.
Calender editors entered by name work ok. I did not check by calendar editors by position.
AT least we can get a calendar printer if we need by having one of the view only members log on to LDS.ORG.
Thank you in advance for your hard work and efforts.
Stake Website Administrator of my Stake.

User avatar
aebrown
Community Administrator
Posts: 14693
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Re: v2.7 bug: Blank printing

Postby aebrown » Tue Nov 25, 2014 10:00 pm

walterfwildman wrote:I have check out the print problem. I appears to be only on Default Administrators.

I suppose it's possible that this printing problem only happens to default administrators, but it definitely doesn't happen to all default administrators -- I am a default administrator, and I have never seen an error generating the PDF for printing.

russellhltn
Community Administrator
Posts: 20767
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: v2.7 bug: Blank printing

Postby russellhltn » Tue Nov 25, 2014 10:25 pm

aebrown wrote:I have never seen an error generating the PDF for printing.

And I assume you've selected all the locations in your stake when trying to print? (Just double-checking.)
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.

User avatar
aebrown
Community Administrator
Posts: 14693
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Re: v2.7 bug: Blank printing

Postby aebrown » Tue Nov 25, 2014 10:47 pm

russellhltn wrote:
aebrown wrote:I have never seen an error generating the PDF for printing.

And I assume you've selected all the locations in your stake when trying to print? (Just double-checking.)

Yep. No error. I've included restrictions or not, I've included any or all or none of the locations, I've tried Week, Agenda, and Month view. It always generates the PDF with no error.

russellhltn
Community Administrator
Posts: 20767
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: v2.7: Error when generating PDF for printing

Postby russellhltn » Wed Nov 26, 2014 2:10 am

I did finally spot a pattern, but it doesn't make much sense. The two locations that work are multi-ward buildings. If I look at the number of units assigned it's 4-5. But all the locations that don't work are single unit locations. Only the stake and the one ward are assigned. But assigning additional units didn't fix it. I've tried every option I can think of to make this other locations work with no luck.
Have you searched the Wiki?

Try using a Google search by adding "site:tech.lds.org/wiki" to the search criteria.


Return to “Calendar”

Who is online

Users browsing this forum: No registered users and 1 guest