Gospel Library: New Testament and PoGP don't work

Discussions around the iPhone/iPad/iPod Touch versions of the Gospel Library application.
robfanny
New Member
Posts: 2
Joined: Sun Dec 25, 2011 6:32 pm

Gospel Library: New Testament and PoGP don't work

Postby robfanny » Sun Dec 25, 2011 6:34 pm

Hi,

I have an iphone 3gs with iOS 4.xxx.

Parts of Gospel Library don't work. ie, scriptures, New Testament and PoGP. I've gone to MANAGE LIBRARY and it says I have the download, but they don't actually show up. I've tried deleting and re-downloading. Says I have the content, but when I go to Scriptures, these scriptures don't work.

Any ideas?

Same problem with some conferences, etc.

PL

lajackson
Community Moderators
Posts: 6139
Joined: Mon Mar 17, 2008 9:27 pm
Location: US

Postby lajackson » Sun Dec 25, 2011 11:33 pm

robfanny wrote:I've gone to MANAGE LIBRARY and it says I have the download, but they don't actually show up. I've tried deleting and re-downloading. Says I have the content, but when I go to Scriptures, these scriptures don't work.


I have a 2nd gen iTouch with iOS 4. I do not have a lot of success with the Manage Library function. But, one thing I have found is that if you go through the motions, wait long enough, and then totally exit Gospel Library and restart it, you will have the files you need more often than not.

I can't tell you how long to wait. And sometimes it takes several exits and restarts. I think the app may be taking a long time to update the database and I am not patient enough. But last I checked, the app does not have any type of display that indicates the amount of patience needed for any particular action.

And once I get a piece, I keep WiFi turned off so that Manage Library does not have a chance to goof it up again.

robfanny
New Member
Posts: 2
Joined: Sun Dec 25, 2011 6:32 pm

Postby robfanny » Mon Dec 26, 2011 10:13 am

Hi,

Got it working. Tried all kinds of work arounds and finally decided to delete the whole app and re-install. That did it. It's working now.

Thanks.

Phil

Naf623
New Member
Posts: 13
Joined: Wed Dec 07, 2011 2:16 am

Postby Naf623 » Fri Dec 30, 2011 12:59 pm

Anyone else having this issue, I have discovered that asking the app to download/install more than a few things at once often does cause a hang/crash.
Suggestions to help prevent it (in my experience):
Don't use the "install all" buttons - much as they are a handy idea, it seems that 'all' is sometimes too much for the device to cope with
Only install a few at a time - afraid I can't give you a number: it may relate to number, total size, availability... Who knows. One at a time is likely to be the most reliable, but I seem to manage fine with 3-5 going.
Only install from one screen at a time, and don't leave it until they're all done - e.g. If there are files still processing from Ensign 1998, don't go back and even look at Ensign 1999 until they're complete.
Don't allow your device to sleep - keep tapping the screen if it dims, or scrolling up and down the list to prevent it dimming, and definitely don't lock it.

The above may make it take longer, and feel slightly awkward: but less so than waiting for the app to crash and relaunch, then having to check if the files are in your library before reinstalling...

lajackson
Community Moderators
Posts: 6139
Joined: Mon Mar 17, 2008 9:27 pm
Location: US

Postby lajackson » Fri Dec 30, 2011 10:12 pm

Naf623 wrote:Anyone else having this issue,


I have every single one of the issues you mention, and I use every single one of the workarounds you have tried, as well, usually successfully, but not always.

The big ones for me are never to use the "Install All" button, to only do one thing at a time, to make sure my iTouch does not sleep during the process, and to not go anywhere or do anything else while trying to update.

It is slow and painful, but not quite as slow and painful as a total delete, reinstall, and download again.

alan.richardson
New Member
Posts: 45
Joined: Sun Oct 11, 2009 5:35 am
Location: Virginia, USA

Postby alan.richardson » Sun Jan 01, 2012 6:39 pm

Having a similar problem so I opted to append vice starting a new thread. Using a 3rd gen iPod Touch running iOS 5. Have Gospel Library 2.4.1 installed (and removed/shutdown/reinstalled/etc.). Prior to upgrading to iOS 5, GL was working fine. Afterwards noticed that the two current temple and family history manuals (under Sunday School) had no content. The old version ("A Member's Guide . . ." but not "Member's Guide . . .") loads fine.

Have tried the above fixes, even loading these manuals first, and still no luck. The "Known Issues" lists "The Living Christ" as having no content, but I see that fine.

Any other suggestions, or should I report it as a bug?

Thanks

lajackson
Community Moderators
Posts: 6139
Joined: Mon Mar 17, 2008 9:27 pm
Location: US

Postby lajackson » Sun Jan 01, 2012 6:43 pm

Alan.Richardson wrote:. . . or should I report it as a bug?


I would report a bug. I think they know about it, but better two reports than none. I only have a 2nd gen and iOS 4 is as far as I can go, so I cannot see this particular problem.


Return to “iPhone/iPad Gospel Library”

Who is online

Users browsing this forum: No registered users and 1 guest