General Conference watching shutdown

Discussions around the Android version of the Gospel Library application.
New Member
Posts: 1
Joined: Mon Jun 29, 2015 4:34 am

General Conference watching shutdown

Postby tdub1016 » Mon Jun 29, 2015 4:35 am

Whenever I try to listen to General through the Gospel Library app, it always shuts down on me. It gives me a message saying Gospel Library has shut down. There is no way for me to change anything, and it happens whenever I try to listen to or watch General Conference.

User avatar
Posts: 288
Joined: Wed Jun 15, 2011 3:12 pm
Location: West Jordan, Utah

Re: General Conference watching shutdown

Postby lmcguire » Mon Jun 29, 2015 6:49 am

Have you tried downloading a talk and then watching / listening to the download? (I'm just trying to determine whether the issue is related to streaming or playing media.) Also, have you tried streaming and/or downloading things other than general conference (so we can know if it's specific to conference or if it's any media)?

That said, it could be device-specific, or it could be that the database / app got corrupted somehow. (Just last week I had to clear all data and re-download everything cuz the database got corrupted somehow.) First, I would power-cycle the device - be sure to leave it powered all the way off for at least 30 seconds. If that doesn't change anything, I know it sounds drastic, but you might consider clearing the data (you'll have to re-download everything), or even uninstalling and re-installing to see if that fixes the problem.

Hopefully the above information may help someone here recognize what's going on. But if not, you'll probably need to use the in-app Help > Feedback option so the developers (who aren't necessarily here) have all your device and version details for troubleshooting.

After writing the above, I decided to test. On my Samsung Galaxy Note 3, I tried the following, in this order, on the most recent general conference:
* Play icon > Listen; worked for a few seconds before I moved on
* Play icon > Watch; Crashed with the same error you have, almost immediately
* power-cycled device to make the next test clean
* Play icon > Download > All media for this page (waited for this to finish)
* Play icon > Listen > From Beginning; let it go through the first three paragraphs with no crashing; paused the playback, then pulled down the notification area and closed the playback (did not do this last time between Listen and Watch)
* Play icon > Watch; video came up as before, let it go through the same three paragraphs (and it's still going). I've switched orientation twice now and it's still going fine.
* I deleted the downloaded media
* Play icon > Listen; let it play through same three paragraphs; paused playback, did NOT close the playback notification thing, just went straight to Play icon > Watch > From Beginning; started (just as before), and it's not crashing - but maybe it's cached. Gonna go try a different talk. Yeah, that last one was cached - this one took a lot longer to come up. It's playing longer than the first one I streamed. Still going 4 minutes later, so I'd say it's not gonna crash.

So it looks like power-cycling may fix it; if that's not true, I'd guess it's either related to switching between two forms of streaming without fully stopping the first (but probably not since I couldn't repeat that), or just streaming itself. And whatever it is, it's not consistent (on my device), which implies that it's either connectivity / networking, or something that's gonna be hard to find...



Return to “Android Gospel Library”

Who is online

Users browsing this forum: No registered users and 1 guest